IBus not working in Firefox 10

RESOLVED WORKSFORME

Status

()

Core
Widget: Gtk
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Nilamdyuti, Unassigned)

Tracking

({inputmethod})

10 Branch
x86
Linux
inputmethod
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Input method framework (IBus) is not working in Firefox 10 Assamese. It is working for other languages. IBus is not recognizing a input window even if its there and is refusing to switch to input methods like Assamese-phonetic, Assamese-inscript etc when ctrl+space (keyboard shortcut for switching input methods) is pressed. IBus is behaving normally for text editors like OpenOffice writer, gedit etc and translation tools like poedit, lokalize etc. Only it doesn't work for an input window in the browser interface.

Steps to reproduce:

1. Enable IBus using im-chooser.

2. Configure the input methods in IBus settings.

3. Run Firefox 10 in as_IN (Assamese)

4. Click on the Google Search box.

5. Press ctrl + space to switch to desired input method other than English (en_US).

Current Result:

Not switching to desired input method other than English (en_US).

Expected Result:

Should switch to desired input method other than English (en_US)
(Reporter)

Updated

6 years ago
Keywords: inputmethod
(Reporter)

Comment 1

6 years ago
I didn't know to which component I should file this bug. Kindly switch it to the correct component.
Component: General → Widget: Gtk
Priority: P3 → --
Product: Firefox → Core
QA Contact: general → gtk
Was this working as expected in Firefox 9?
(Reporter)

Comment 3

6 years ago
Firefox 9 wasn't available in Assamese. After Firefox 3.6, Firefox 10 is the omly release for Assamese.
Could you attach a log file when you do only the steps in comment 0?

See bug 636131 comment 10 for recording our IME handling behavior.
(Reporter)

Comment 5

6 years ago
Created attachment 597768 [details]
Log file after doing the steps mentioned in https://bugzilla.mozilla.org/show_bug.cgi?id=727727#c0
Hmm, it's strange. The log looks fine for me.

> -143173376[f75391c0]: GtkIMModule(f20796a0): Focus, sLastFocusedModule=f20796a0
> -143173376[f75391c0]: GtkIMModule(f20796a0): OnFocusChangeInGecko, aFocus=YES mIsComposing=NO, mIsIMFocused=YES, mIgnoreNativeCompositionEvent=NO

We set focus to the IM context,

> -143173376[f75391c0]: GtkIMModule(f20796a0): OnKeyEvent, aCaller=f14f2980, aKeyDownEventWasSent=FALSE
> -143173376[f75391c0]:     aEvent: type=GDK_KEY_PRESS, keyval=Control_L, unicode=0x0
> -143173376[f75391c0]:     filterThisEvent=FALSE (isFiltered=NO, mFilterKeyEvent=YES)
> -143173376[f75391c0]: GtkIMModule(f20796a0): OnKeyEvent, aCaller=f14f2980, aKeyDownEventWasSent=FALSE
> -143173376[f75391c0]:     aEvent: type=GDK_KEY_PRESS, keyval=space, unicode=0x20
> -143173376[f75391c0]:     filterThisEvent=FALSE (isFiltered=NO, mFilterKeyEvent=YES)

We passed both the left Ctrl key event and the space key event to GTK2 IM Module.

Nilamdyuti:

What distribution are you using? I would need to create same environment if I couldn't reproduce this bug on my environment.
(Reporter)

Comment 7

6 years ago
Masayuki,

I am using RHEL 6 csb. I found the same issue in Fedora 16 as well.
Thanks, when I have much time next week, I'll check this bug.

Comment 9

6 years ago
Firefox 9 and 10 both do not work for languages which use ibus 1.3.x versions. Am removing the language tag as this is not restricted to only Assamese. Thanks.
Summary: [as_IN]IBus not working in Firefox 10 (Assamese) → IBus not working in Firefox 10

Comment 10

6 years ago
Sorry, the earlier message should have read as:

'Both on Firefox 9 and 10 it (i.e. inputmethod) does not work for languages which use ibus 1.3.x versions'

Comment 11

6 years ago
This was caused by a mismatch of the libraries. The problem was encountered on 64 bit machines after firefox was updated to 32 bit versions by following the update links that pointed to the 32 bit versions. A re-install of the 64 bit firefox versions resolved the problem.
marking wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.