Crash in nsObjectFrame::StopPluginInternal @ nsPluginInstanceOwner::PrepareToStop

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, topcrash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash][mobile-crash], crash signature)

(Reporter)

Description

6 years ago
It has been hit by 3 different users in 12.0a2.

Signature 	nsPluginInstanceOwner::PrepareToStop More Reports Search
UUID	e153ec26-19d2-408b-85b9-759032120213
Date Processed	2012-02-13 20:21:32
Uptime	174
Last Crash	3.0 minutes before submission
Install Age	4.1 hours since version was first installed.
Install Time	2012-02-13 16:14:33
Product	FennecAndroid
Version	12.0a2
Build ID	20120213042011
Release Channel	aurora
OS	Linux
OS Version	0.0.0 Linux 2.6.35.7-I9100MUGKG2-CL371789 #2 SMP PREEMPT Tue Jul 12 10:46:35 KST 2011 armv7l
Build Architecture	arm
Build Architecture Info	
Crash Reason	SIGSEGV
Crash Address	0x10
User Comments	
App Notes 	
EGL? EGL+
AdapterVendorID: smdkc210, AdapterDeviceID: GT-I9100M.
AdapterDescription: 'Android, Model: 'GT-I9100M', Product: 'GT-I9100M', Manufacturer: 'samsung', Hardware: 'smdkc210''.
samsung GT-I9100M
samsung/GT-I9100M/GT-I9100M:2.3.3/GINGERBREAD/UGKG2:user/release-keys	
EMCheckCompatibility	True

Frame 	Module 	Signature [Expand] 	Source
0 	libxul.so 	nsPluginInstanceOwner::PrepareToStop 	dom/plugins/base/nsPluginInstanceOwner.cpp:2826
1 	libxul.so 	nsObjectFrame::StopPluginInternal 	layout/generic/nsObjectFrame.cpp:2516
2 	libxul.so 	nsObjectFrame::DestroyFrom 	layout/generic/nsObjectFrame.cpp:354
3 	libxul.so 	nsBlockFrame::DoRemoveFrame 	layout/generic/nsIFrame.h:582
4 	libxul.so 	nsBlockFrame::RemoveFrame 	layout/generic/nsBlockFrame.cpp:5028
5 	libxul.so 	nsFrameManager::RemoveFrame 	layout/base/nsFrameManager.cpp:537
6 	libxul.so 	nsCSSFrameConstructor::ContentRemoved 	layout/base/nsCSSFrameConstructor.cpp:7565
7 	libxul.so 	nsCSSFrameConstructor::RecreateFramesForContent 	layout/base/nsCSSFrameConstructor.cpp:9163
8 	libxul.so 	nsCSSFrameConstructor::ProcessRestyledFrames 	layout/base/nsCSSFrameConstructor.cpp:8007
9 	libxul.so 	mozilla::css::RestyleTracker::ProcessOneRestyle 	layout/base/RestyleTracker.cpp:164
10 	libxul.so 	mozilla::css::RestyleTracker::DoProcessRestyles 	layout/base/RestyleTracker.cpp:242
11 	libxul.so 	nsCSSFrameConstructor::ProcessPendingRestyles 	layout/base/RestyleTracker.h:101
12 	libxul.so 	PresShell::FlushPendingNotifications 	layout/base/nsPresShell.cpp:4073
13 	libxul.so 	nsRefreshDriver::Notify 	layout/base/nsRefreshDriver.cpp:406
14 	libxul.so 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:431
15 	libxul.so 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:524
16 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:657
17 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
18 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
19 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
20 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
21 	libxul.so 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:189
22 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:220
23 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3537
...

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsPluginInstanceOwner%3A%3APrepareToStop
(Reporter)

Updated

6 years ago
Whiteboard: [native-crash] → [native-crash][mobile-crash]
Version: 12 Branch → unspecified
(Reporter)

Comment 1

6 years ago
It's #1 top crasher in Fennec 11.0b4 with dupes and #9 without dupes.
Dupes mean it seems easily reproducible.
Keywords: topcrash
css + flash + timing... possibly closing of tab?  Need to try to duplicate

http://www.engadget.com/ 
http://http://www.jibjab.com/originals/this_land
http://www.fox.com/familyguy/quiz/quagmire-trivia 
http://www.bw-rhynern.de/index.html

Comment 3

6 years ago
No crashes in anything over the last 4 weeks except Fennec 11. Resolving as worksforme.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.