Video scrubber is locked

VERIFIED FIXED in Firefox 13

Status

()

P2
normal
VERIFIED FIXED
7 years ago
5 years ago

People

(Reporter: xti, Unassigned)

Tracking

Trunk
Firefox 13
ARM
Android
Points:
---
Bug Flags:
in-litmus +

Firefox Tracking Flags

(firefox12 affected, firefox13 verified, blocking-fennec1.0 beta+)

Details

(Reporter)

Description

7 years ago
Firefox 13.0a1 (2012-02-16)
20120216031231
http://hg.mozilla.org/mozilla-central/rev/a853f4017192
Device: Motorola Droid PRO
OS: Android 2.3.3

Steps to reproduce:
1. Open Fennec
2. Go to http://people.mozilla.com/~nhirata/html_tp/big_buck_bunny_480p.webm
3. Tap on screen for video controls
4. Tap on scrubber bar to skip back and forward in the video

Expected results:
The video will continue playing from the point where the last tap was performed.

Actual result:
Video scrubber doesn't work at all.

Note:
Even if video is switched to full screen mode, there will be the same actual result.
tracking-fennec: --- → ?
fixed by bug 727817?
Keywords: fennecnative-betablocker
Priority: -- → P2
This should have been fixed by bug 727817.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
based on Bug 729705... isn't this a dup of bug 657791?  He's using the same video.  We need to change the test case.
Well, 727817 made the scrubber "work" on video's, even this one (need to add touch events supports for xul scale elements now so that you can drag them. I think there's a bug for that somewhere...).

This particular video just hits a different issue now that the scrubber does work.
Ah.  Fair enough.  We would still need to change the test case. Setting myself to do that.
Flags: in-litmus?(nhirata.bugzilla)
blocking-fennec1.0: --- → beta+
http://introducinghtml5.com/examples/ch04/ch4-full-fallback.html is a better test case; scrubber works.

litmus case : 48656, 48668 changed
Flags: in-litmus?(nhirata.bugzilla) → in-litmus+
(Reporter)

Comment 7

7 years ago
The scrubber is not locked anymore, but still I cannot forward the video to a desired point. If I try to do that, it will forward automatically to its end and there is no way to make the video to play from the beginning, except reloading the page or load it in a new tab.
The scrubber should move regarding the finger movement, until it will be released of the screen. Reopening bug

--
Firefox 13.0a1 (2012-03-01)
Device: Samsung Galaxy S2
OS: Android 2.3.4
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 8

7 years ago
(In reply to Cristian Nicolae (:xti) from comment #7)
> The scrubber is not locked anymore, but still I cannot forward the video to
> a desired point. If I try to do that, it will forward automatically to its
> end and there is no way to make the video to play from the beginning, except
> reloading the page or load it in a new tab.
> The scrubber should move regarding the finger movement, until it will be
> released of the screen. Reopening bug

Cristian, do you mean you want to be able to drag your finger and have the scrubber follow it? If so, I think we should file a different bug about that because AIUI that's a harder problem that XUL fennec didn't even solve (wesj mentioned this in comment 4).

If you single tap on different points on the scrubber bar, does the video move to that point? If so, we should mark this bug as FIXED.
(Reporter)

Comment 9

7 years ago
(In reply to Margaret Leibovic [:margaret] from comment #8)
> 
> Cristian, do you mean you want to be able to drag your finger and have the
> scrubber follow it? If so, I think we should file a different bug about that
> because AIUI that's a harder problem that XUL fennec didn't even solve (wesj
> mentioned this in comment 4).
> 
> If you single tap on different points on the scrubber bar, does the video
> move to that point? If so, we should mark this bug as FIXED.

I will file a bug for the dragging case.

I tried to do a single tap, and as I mentioned in my previous comment, the scrubber goes automatically to the end of the video and it cannot be reset, only by reloading the page or loading it in a new tab.
The video listed here suffers from bug 657791. See comment 6.
(Reporter)

Comment 11

7 years ago
Testing this using the video from comment 6, everything works as expected. Should I close this bug in this case?

Also bug 732052 was filled regarding the dragging issue. As Wesley said, we should use touch events for video scrubber
(Reporter)

Comment 13

7 years ago
(In reply to Naoki Hirata :nhirata from comment #12)
> Try using this video:
> http://introducinghtml5.com/examples/ch04/ch4-full-fallback.html

It works as expected using this video. I will close the bug as:

Verified fixed on:

Firefox 13.0a1 (2012-03-01)
20120301031135
http://hg.mozilla.org/mozilla-central/rev/1c3b291d0830

--
Device: Samsung Galaxy S2
OS: Android 2.3.4
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Reporter)

Updated

7 years ago
Status: RESOLVED → VERIFIED
status-firefox13: affected → verified
Target Milestone: --- → Firefox 13
(Assignee)

Updated

5 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.