rewrite getter_AddRefs(pAddressLists->ElementAt(j)) using QueryElementAt

VERIFIED FIXED

Status

SeaMonkey
MailNews: Address Book & Contacts
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: timeless, Assigned: standard8)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
from Bugzilla Bug 70989 Clean up lots of "shadows" and other common warnings 
 * mailnews/addrbook:
   - nsCOMPtr<nsISupports> pSupport =    
         getter_AddRefs(pAddressLists->ElementAt(j));
   + pSupport = getter_AddRefs(pAddressLists->ElementAt(j));
     nsCOMPtr<nsIAbCard> cardInList(do_QueryInterface(pSupport, &rv));
   You have tabs here in your + line, and can we use QueryElementAt to save the
   explicit QI?
QA Contact: esther → stephend
Reversing database corruption caused by bug 95857 and bug 95798.  Pay no
attention to the man behind the curtain.
(Reporter)

Comment 2

16 years ago
note to self: I think I have another bug somewhere else about this.  (Those who
fail to patch before are bound to report their bugs again and patch later...)
Status: NEW → ASSIGNED
Whiteboard: DUPEME
Product: Browser → Seamonkey
(Assignee)

Comment 3

13 years ago
Timeless said (over irc) I could take this one off him, therefore re-assigning.
Assignee: timeless → bugzilla
Status: ASSIGNED → NEW
Whiteboard: DUPEME
(Assignee)

Comment 4

13 years ago
Created attachment 183763 [details] [diff] [review]
Patch

This patch fixes the only case I could find in address book where this happens.
Attachment #183763 - Flags: superreview?(bienvenu)
Attachment #183763 - Flags: review?(bienvenu)
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED

Updated

13 years ago
Attachment #183763 - Flags: superreview?(bienvenu)
Attachment #183763 - Flags: superreview+
Attachment #183763 - Flags: review?(bienvenu)
Attachment #183763 - Flags: review+
(Assignee)

Comment 5

13 years ago
Comment on attachment 183763 [details] [diff] [review]
Patch

Requesting approval for checkin for this minor change - it is a small code tidy
up that affects both suite & tb, but should be low risk.
Attachment #183763 - Flags: approval1.8b2?
Attachment #183763 - Flags: approval-aviary1.1a1?

Comment 6

13 years ago
Comment on attachment 183763 [details] [diff] [review]
Patch

a=asa for checkin to 1.8b2/1.1a1
Attachment #183763 - Flags: approval1.8b2?
Attachment #183763 - Flags: approval1.8b2+
Attachment #183763 - Flags: approval-aviary1.1a1?
(Assignee)

Comment 7

13 years ago
Timeless checked this in:

2005-05-19 13:22	timeless%mozdev.org 	mozilla/ mailnews/ base/ resources/
locale/ en-US/ messenger.properties 	1.118 	1/1
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

13 years ago
Opps try getting the right checkin ;-)

2005-05-19 13:21	timeless%mozdev.org 	mozilla/ mailnews/ addrbook/ src/
nsDirectoryDataSource.cpp 	1.66 	3/3
QA Contact: stephend → technutz
Verified FIXED (API-level) using LXR:

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/mailnews/addrbook/src&command=DIFF_FRAMESET&file=nsDirectoryDataSource.cpp&rev1=1.65&rev2=1.66&root=/cvsroot
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.