Video controls should allow changing volume

RESOLVED WONTFIX

Status

()

Firefox for Android
General
P5
enhancement
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: xti, Unassigned, Mentored)

Tracking

({uiwanted})

Trunk
ARM
Android
uiwanted
Points:
---

Firefox Tracking Flags

(firefox12 affected, firefox13 affected, fennec+)

Details

(Reporter)

Description

6 years ago
Firefox 13.0a1 (2012-02-16)
20120216031231
http://hg.mozilla.org/mozilla-central/rev/a853f4017192
Device: Motorola Droid PRO
OS: Android 2.3.3

Steps to reproduce:
1. Open Fennec
2. Go to http://people.mozilla.com/~nhirata/html_tp/big_buck_bunny_480p.webm
3. Tap on screen for video controls
4. Tap on volume button
5. Repeat step 4
6. Move the slider up or down to raise or lower the volume

Expected result:
After step 4, the Volume Control bar is displayed.
After step 5, the sound is muted
After step 6, the sound level will be accordingly to the slider position

Actual result:
Tapping on the Volume button, nothing will happen.
tracking-fennec: --- → ?
This should have been fixed by bug 727817.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

6 years ago
The video sound can be muted now, but it cannot be adjust to a desired level using the volume slider. Reopening bug

Tested on: http://introducinghtml5.com/examples/ch04/ch4-full-fallback.html

--
Firefox 13.0a1 (2012-03-05
Device: HTC Desire
OS: Android 2.2
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Adjusting summary then, but I think UX should WONTFX this since (all?) devices have hardware volume buttons. Most video players on devices don't seem to offer volume controls either.
Summary: Video's sound cannot be adjusted or muted → Video controls should allow changing volume
Passing this to UX.  It is a cool idea; I agree with wesj for this though.
Severity: normal → enhancement
tracking-fennec: ? → +
Whiteboard: [mentor=wesj]
(Assignee)

Updated

4 years ago
Mentor: wjohnston
Whiteboard: [mentor=wesj]
filter on [mass-p5]
Priority: -- → P5

Comment 6

2 years ago
I thought we discussed this and decided that it's not a good UX idea to include volume controls in the video, since it would be hard to create finger-friendly controls in such a small space.

antlam, should we WONTFIX this?
Flags: needinfo?(alam)
Yeah this is a WONTFIX, I can't find the dupe ATM though.

Video controls will allow for muting/unmuting but not volume level control. That's going to be reserved for the phone controls.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago2 years ago
Flags: needinfo?(alam)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.