Closed Bug 727826 Opened 9 years ago Closed 9 years ago

Use JSON.parse() in HistoryMenu.prototype.populateUndoSubmenu()

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 13

People

(Reporter: tetsuharu, Assigned: tetsuharu)

Details

Attachments

(1 file)

In in HistoryMenu.prototype.populateUndoSubmenu(), it should use JSON.parse() insetad of using eval().
OS: Windows 7 → All
Hardware: x86_64 → All
Attachment #597807 - Flags: review?(mak77)
Assignee: nobody → saneyuki.s.snyk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 597807 [details] [diff] [review]
proposed patch

Review of attachment 597807 [details] [diff] [review]:
-----------------------------------------------------------------

good catch, looks like this is there from quite some time and I don't see a valid reason for it. This code goes back to 2006, likely we didn't yet have native json.
Attachment #597807 - Flags: review?(mak77) → review+
Thanks for the patch! In future, could you follow the instructions at http://blog.bonardo.net/2010/06/22/so-youre-about-to-use-checkin-needed so that your patches include an author and commit message? That will make it easier for other people to check them in.

http://hg.mozilla.org/integration/mozilla-inbound/rev/1c86e1c24cbc
https://hg.mozilla.org/mozilla-central/rev/1c86e1c24cbc
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 13
You need to log in before you can comment on or make changes to this bug.