Last Comment Bug 727884 - Make nsWrapperCache::WrapObject take a JSObject scope instead of XPCWrappedNativeScope
: Make nsWrapperCache::WrapObject take a JSObject scope instead of XPCWrappedNa...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla14
Assigned To: Blake Kaplan (:mrbkap)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-16 09:46 PST by Blake Kaplan (:mrbkap)
Modified: 2012-03-15 08:01 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1 (11.61 KB, patch)
2012-02-16 09:46 PST, Blake Kaplan (:mrbkap)
peterv: review+
mrbkap: checkin+
Details | Diff | Splinter Review

Description Blake Kaplan (:mrbkap) 2012-02-16 09:46:48 PST
Created attachment 597870 [details] [diff] [review]
patch v1

For the new DOM bindings, we won't have XPCWrappedNatives lying around. However, we are going to piggy-back on nsWrapperCache::WrapObject, so that function's signature needs to be amenable to both the old and new world.
Comment 1 Peter Van der Beken [:peterv] - away till Aug 1st 2012-02-21 06:25:16 PST
Comment on attachment 597870 [details] [diff] [review]
patch v1

Review of attachment 597870 [details] [diff] [review]:
-----------------------------------------------------------------

Looks like you might be able to wrap a lot of the lines where you did s/XPCWrappedNativeScope/JSObject/.
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2012-03-03 08:47:22 PST
Blake, anything stopping this from landing on central?
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2012-03-05 10:36:14 PST
Except from Peter's bitrot, that is...
Comment 4 Blake Kaplan (:mrbkap) 2012-03-14 09:40:57 PDT
Comment on attachment 597870 [details] [diff] [review]
patch v1

https://hg.mozilla.org/integration/mozilla-inbound/rev/c5af61992920 with some merging.
Comment 5 Marco Bonardo [::mak] (Away 6-20 Aug) 2012-03-15 08:01:46 PDT
https://hg.mozilla.org/mozilla-central/rev/c5af61992920

Note You need to log in before you can comment on or make changes to this bug.