MAPLE: Crash in libGLESv2_POWERVR_SGX530_121.so when loading pages on the Motorola Milestone

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
P2
critical
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Martijn Wargers (zombie), Unassigned)

Tracking

({crash})

14 Branch
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 beta+)

Details

(Whiteboard: MAPLE [gfx][native-crash], crash signature)

(Reporter)

Description

6 years ago
When trying the Maple build on my Motorola Milestone, I crash almost on every page.
Tested on Maple build of 2012-02-16.

https://crash-stats.mozilla.com/report/index/93a5afb5-c872-4d44-a715-a1c102120216
0 	libc.so 	memcpy 	
1 	libGLESv2_POWERVR_SGX530_121.so 	libGLESv2_POWERVR_SGX530_121.so@0x21042 	
2 	libGLESv2_POWERVR_SGX530_121.so 	libGLESv2_POWERVR_SGX530_121.so@0x4a326 	
3 	libGLESv2_POWERVR_SGX530_121.so 	libGLESv2_POWERVR_SGX530_121.so@0x42572 	
4 	libGLESv2_POWERVR_SGX530_121.so 	libGLESv2_POWERVR_SGX530_121.so@0x1cd02 	
5 	libGLESv2_POWERVR_SGX530_121.so 	libGLESv2_POWERVR_SGX530_121.so@0x20812 	
6 	libGLESv2_POWERVR_SGX530_121.so 	libGLESv2_POWERVR_SGX530_121.so@0x1cd02 	
7 		@0x7ffe 	
8 	libGLESv2_POWERVR_SGX530_121.so 	libGLESv2_POWERVR_SGX530_121.so@0x42572 	
9 	libGLESv2_POWERVR_SGX530_121.so 	libGLESv2_POWERVR_SGX530_121.so@0x42572 	
10 	libc.so 	pthread_mutex_unlock 	

The GPU drivers of this device can be found here:
http://people.mozilla.com/~mwargers/glat2/drivers_milestone/

Updated

6 years ago
Crash Signature: [@ memcpy | libGLESv2_POWERVR_SGX530_121.so@0x21042]
Summary: MAPLE: Crash [@ memcpy] when loading pages on the Motorola Milestone → MAPLE: Crash in libGLESv2_POWERVR_SGX530_121.so when loading pages on the Motorola Milestone
Keywords: fennecnative-betablocker
(Reporter)

Comment 1

6 years ago
I just tried today's Maple build on the Motorola Milestone, it's still crashing.
Priority: -- → P2
blocking-fennec1.0: --- → beta+

Comment 2

6 years ago
If this is still happening, do we need to block this particular device?
We shouldn't block the device until we verify that it's not a bug in our code. Having a Milestone would help.
Perhaps we should ask QA to run a few simple GL android application. This should be a good smoke test.

Comment 5

6 years ago
(In reply to Benoit Girard (:BenWa) from comment #4)
> Perhaps we should ask QA to run a few simple GL android application. This
> should be a good smoke test.

Sure, point a good one out.  We can add it to our smoketest suite.

Comment 6

6 years ago
(In reply to Joe Drew (:JOEDREW!) from comment #3)
> We shouldn't block the device until we verify that it's not a bug in our
> code. Having a Milestone would help.

Do we need to wait until the remaining maple patches land before checking this?
No. Those patches affect rendering correctness, not crashiness.
Whiteboard: MAPLE → MAPLE [gfx]
(Reporter)

Comment 8

6 years ago
Benoit mentioned on irc Quadrant Standard Edition as an app to test with.

I tested this on the Motorola Milestone, this app doesn't crash on that phone.

I just tested today's trunk build (which contains the merge from Maple branch) and it still crashes after loading cnn.com and zooming in.

Updated

6 years ago
Whiteboard: MAPLE [gfx] → MAPLE [gfx][native-crash]
Version: Trunk → Firefox 14
no crashes with this signature since the 28th
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 10

6 years ago
I don't get crashes anymore with the latest trunk build. However, current trunk build hangs very quickly after loading a web page on the Motorola Milestone, so I filed bug 742243 for that.
You need to log in before you can comment on or make changes to this bug.