Search Bookmarks window has no close box when invoked from Manage Bookmarks window

VERIFIED FIXED

Status

SeaMonkey
Bookmarks & History
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: gsa, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; N; PPC; en-US; 0.8.1) Gecko/20010320
BuildID:    2001032008

access Bookmarks menu:Manage Bookmarks menu:Edit menu:Search Bookmarks menu,
Search Bookmarks window has no close box can't close it


Reproducible: Always
Steps to Reproduce:
1. access Bookmarks menu:Manage Bookmarks menu:Edit menu:Search Bookmarks menu
Search Bookmarks window has no close box can't close it
2.look at upper left corner of Search Bookmarks window, no close box
3. if step 1 is repeated the Search Bookmarks window doesnt appear at all

Actual Results:  couldn't close Search Bookmarks window
couldn't perform step 1

Expected Results:  should have been able to close Search Bookmarks window
and performed step 1 again
confirming.  This is a problem on Linux also.  If this is a window, it should
have a close box on the titlebar, if this is a dialog it should have a close button.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: mozilla0.9
OS: Mac System 9.x → All
Hardware: Macintosh → All
Created attachment 28362 [details] [diff] [review]
make this invocation of this dialog like all the other ones
adding keywords
Keywords: patch, review
I removed the 'centerscreen' property of the dialog because no other invocation
of it has it.  Should that be put back in?  It does nothing that I can detect on
Linux, but it may do something useful on MacOS....

I should clarify. 'dialog=no,close,centerscreen' makes my windowmanager position
the window and it has a close box on the titlebar.  'close,centerscreen' on its
own will center the window instead of having the WM position it, and there is no
close box.

Comment 5

18 years ago
tweaking summary to make this more obvious. I note that on MacOS the dialog when invoked
from Manage Bookmarks has its own resize widget in the bottom right corner of the window instead
of the native MacOS one like it should. What's that about?
Summary: Search Bookmarks window has no close box can't close it → Search Bookmarks window has no close box when invoked from Manage Bookmarks window

Comment 6

17 years ago
I used to see this also on Windows, but it looks as if it's since been fixed.  
(Boris, please feel free to file a new bug on removing the centerscreen arg if 
you want; it probably should be removed so the window position is persisted 
instead of the window centering each time).  Let me know if the problem remains 
on mac; that would be strange.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.