MAPLE: Phone icon doesn't display on ICS

VERIFIED FIXED in Firefox 14

Status

()

Firefox for Android
General
P1
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: nhirata, Assigned: gw280)

Tracking

Trunk
Firefox 14
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 beta+)

Details

(Whiteboard: MAPLE mwc-demo, URL)

Attachments

(2 attachments)

1. go to http://paulrouget.com/mwc-demos/apis/orientation.html
2. hit the home button on the phone
3. go back to maple

Expected: phone icon that tilts based on orientation
Actual: black box icon that tilts based on orientation

Note:
1. nonICS will recall the correct icon after a moment; ICS will remain black until you over rotate the phone
2. should the phone disappear?
3. should the phone match the tilt angle of the actual phone?
4. MAPLE 2/16/2012; Galaxy Nexus ICS, LG Revolution 2.3

Updated

6 years ago
Blocks: 728249
not mwc demo specific.
Whiteboard: MAPLE mwc-demo → MAPLE
This works fine on my Galaxy S 2. On a Galaxy Nexus (ICS), I either don't see the phone image, or I see it for a brief moment and then it disappears.
Summary: MAPLE: phone icon turns into a black box after hitting home and coming back to the app → MAPLE: Phone icon doesn't display on ICS
Assignee: nobody → gwright

Updated

6 years ago
Priority: -- → P2
Whiteboard: MAPLE → MAPLE mwc-demo

Updated

6 years ago
No longer blocks: 728249
Keywords: fennecnative-betablocker
This looks like the texture's being deleted underneath us. Still investigating.

Updated

6 years ago
Priority: P2 → P1
blocking-fennec1.0: --- → beta+
Created attachment 600495 [details] [diff] [review]
Bug 728041 - Only release the surface and not the context. Turns out calling eglMakeCurrent with the context set to the current context, but everything else set to NULL, does the right thing for us. r=ajuma?
Attachment #600495 - Flags: review?(jmuizelaar)
Attachment #600495 - Flags: review?(ajuma)
(Assignee)

Updated

6 years ago
Whiteboard: MAPLE mwc-demo → [autoland-try:600495] MAPLE mwc-demo

Updated

6 years ago
Whiteboard: [autoland-try:600495] MAPLE mwc-demo → [autoland-in-queue] MAPLE mwc-demo

Updated

6 years ago
Attachment #600495 - Flags: review?(ajuma) → review+

Comment 5

6 years ago
Pushed to maple: https://hg.mozilla.org/projects/maple/rev/d50f3465ce17
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 6

6 years ago
Autoland Patchset:
	Patches: 600495
	Branch: mozilla-central => try
Error applying patch 600495 to mozilla-central.
patching file gfx/gl/GLContextProviderEGL.cpp
Hunk #1 FAILED at 1172
1 out of 1 hunks FAILED -- saving rejects to file gfx/gl/GLContextProviderEGL.cpp.rej
abort: patch failed to apply

Could not apply and push patchset:

Updated

6 years ago
Whiteboard: [autoland-in-queue] MAPLE mwc-demo → MAPLE mwc-demo
Attachment #600495 - Flags: review?(jmuizelaar) → review+

Updated

6 years ago
Depends on: 735230
Target Milestone: --- → Firefox 14
The issue is still reproducible on Nightly/15.0a1 2012-05-02 on the Samsung Galaxy Nexus (Android 4.0.2). The phone icon is a lot smaller then on other phones (HTC Desire running Android 2.2) and disappears when the device is rotated.
Also from Comment 6 it seems that the patch failed to be integrated. Reopening the issue.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 8

6 years ago
(In reply to adrian tamas from comment #7)
> The issue is still reproducible on Nightly/15.0a1 2012-05-02 on the Samsung
> Galaxy Nexus (Android 4.0.2). The phone icon is a lot smaller then on other
> phones (HTC Desire running Android 2.2) and disappears when the device is
> rotated.

Testing on a Galaxy Nexus using the latest Nightly, the size of the phone icon seems to depend on the vertical tilt of the device (that is, tilting in one direction makes the icon larger, and tilting in the other makes the icon smaller until it disappears). Even after rotating or going to the home screen, the icon is still visible (and its size can still be changed by the tilt of the device, including getting smaller to the point of no longer being visible).

Do you have steps to reproduce where the phone icon disappears and remains invisible even when the tilt of the device is changed?

Updated

6 years ago
Keywords: qawanted
Created attachment 620299 [details]
logs

I am able to reproduce the issue when simply rotating the device. Attaching logs and please see the video of the issue: http://youtu.be/EX8aUezBvBM . I also do not see any difference in the size of the icon when rotating the device. 

The device used in the video is the Samsung Galaxy Nexus running Android 4.0.2 and Nightly/15.0a1 2012-05-02.
Keywords: qawanted

Comment 10

6 years ago
(In reply to adrian tamas from comment #9)
> Created attachment 620299 [details]
> logs
> 
> I am able to reproduce the issue when simply rotating the device. Attaching
> logs and please see the video of the issue: http://youtu.be/EX8aUezBvBM . I
> also do not see any difference in the size of the icon when rotating the
> device. 

Does tilting (without rotating) the device make the icon come back? That is, if the device is rotated into landscape (as in the video), and then you tilt (not rotate) to the right (while still in landscape) do you see the icon returning?
If I tilt the phone to the side 45' then I see the largest icon - but still smaller then on the HTC Desire. Tilting it around this point I can see the icon shrinking or growing but only over a few degrees of tilt. From a point forward/backward the icon is no longer displayed.

Comment 12

6 years ago
To help debug this, I've made a copy of this demo where the phone icon is no longer scaled by the tilt: http://people.mozilla.org/~ajuma/bug728041/

With this version:
-On a Galaxy Nexus, the phone icon doesn't appear on page load, but does appear when we slightly zoom in. However, if we pan so that the phone icon is near the bottom of the page, it disappears again.
-On a Nexus S, the icon does appear on page load, but as with the Galaxy Nexus, disappears if the icon is near the bottom of the page.

This is a different issue from what this bug was originally about. This bug was about a black box replacing the phone icon, which turned out to be caused by failed texture upload.

The new issue issue seems to be an invalidation problem. I think we should close this bug again, and open a new bug for the new issue.

Comment 13

6 years ago
(In reply to Ali Juma [:ajuma] from comment #12)
> The new issue issue seems to be an invalidation problem. I think we should
> close this bug again, and open a new bug for the new issue.

Filed Bug 751190 for the new issue, so closing this one again.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Based on Comment 13 and the previous discussion in the bug closing the issue as verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.