derstandard.at - three columns are not displayed next to each other

VERIFIED FIXED

Status

Tech Evangelism Graveyard
German
P4
minor
VERIFIED FIXED
18 years ago
3 years ago

People

(Reporter: Robert Pollak, Assigned: Tristan Nitot)

Tracking

Details

(URL)

(Reporter)

Description

18 years ago
The first and second column of http://derstandard.at/standard.asp are displayed
at the lower end of the third column.
They should also start at the page top (as seen with ns4.7).
webmaster@DerStandard.at told me that it's mozilla's fault - they use 'java
script commands that are more complicated' :)

(I use build 2001032004, installed on win2k)

Comment 1

18 years ago
here we have primar 3 absolute positioned divs, where the news content is in.
the lines between that are drawed by a java-script that reads the high by a 
java-script.

Comment 2

18 years ago
The column layout reported in this bug was fixed by cleaning up the MANY nesting
errors in the HTML.  Christoph, you would do well to run your work through an
HTML validator.  Since Mozilla is a standards-compliant browser it is not as
forgiving of poor HTML code as other browsers.

The javascript line generation still doesn't work, but you can work on that once
you've got a solid HTML foundation.

Comment 3

18 years ago
Marking INVALID this is a problem in the HTML not our problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

17 years ago
As derstandard.at is afaik one of Austria's most popular websites:
Shouldn't this bug be left open and moved to component:evangelism instead?
(Quote of component description: "to track web pages that must be upgraded to
support web standards")

This bug *is* annoying!
Until fixed, I recommend reading other Austrian online news instead ;)

E.g. http://www.diepresse.at/ , http://nachrichten.at/ or http://orf.at/ work
fine with Mozilla (although none of them validates at http://validator.w3.org/
either.)

BTW: Does this bug also appear on Linux?

Comment 5

17 years ago
The site uses document.layers and doesn't seem to recognize mozilla as a browser
that doesn't support it. Isn't solving this simply to fix up the browser
sniffing code? Similar bug about same site is now reported in bug 85545.
Status: RESOLVED → UNCONFIRMED
Component: Layout → Evangelism
Resolution: INVALID → ---
This should be evangelism.  RE-OPENING to move there.
-> Evangelistas.
Assignee: karnaze → bclary
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: petersen → zach
*** Bug 91514 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
hi again.

until we now rebuid our frameset (u see, its not compliant to mozilla, our 
fault), i also tracked the error.
first, as i said, there are 3 div's absolutly positioned (no top coordinate 
enterd). and under these is our copyright over the whole width of the site. so 
it cannot be in one of the divs.
so we detect the height of the longest div with javascript and write a 1px gif 
after the divs on the left side of the page, that the copyright appers on the 
bottom of the page.

so what mozilla does (as the only browser, i tried it on ns,ie,opera,konqueror)
is to draw the gif bevore the divs and draw the divs at the end of the gif.

and í think we also tried it at mozilla 0.6 and it worked there....

and one question to the programmers:
we are working on a new frameset. and it should be function on mozilla. so 
should we build now a workaround on the bug, or do you will fix it?

wish u all a nice week,

christoph richter

Comment 10

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 11

17 years ago
-> Euro
Assignee: bclary → nitot
Component: US English → European
QA Contact: zach → momoi

Comment 12

17 years ago
This worksforme now with build 2001082303 - great!
Did you improve your  html code, webmaster@derstandard.at?
(Assignee)

Comment 13

17 years ago
WFM, excepted a larger space at the end of the document. Setting to P4.
Apparently, good job from the webmaster to improve the HTML.
Status: NEW → ASSIGNED
Priority: -- → P4

Comment 14

17 years ago
Moving to new component "West Europe".  European component is being removed. 
See bug 95808 for details.
Status: ASSIGNED → NEW
Component: European → West Europe
QA Contact: momoi → caillon
Summary: three columns are not displayed next to each other → derstandard.at - three columns are not displayed next to each other

Comment 15

17 years ago
*** Bug 106697 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
From duped bug 106697:

While most of the page renders OK, some important details dont work
with mozilla: the steering weel should open/close the menu having
"Newsroom, Zeitung, Wireless" and should be on the far left of
the bottom menu. Instead, the steering wheel is in the far right 
and the menu always open at a wrong position.  The ad banner is not
 shown correctly. If going to a
subpage by clicking e.g. "Politik" in the top menu, the 
"Ubersicht" menu to the left is not shown. 
This is now unchanged for over a year,
I have contacted the web master two times.

The site has been reorganized and works well now. Can somebody makr as
fixed and verify?

Comment 18

17 years ago
I have reported this bug, and I'd like to mark it fixed, but I can't, because my
old bugzilla account 'r_pollak@handata.com' does not work any more.
(This email adress is invalid for half a year now.)

Comment 19

17 years ago
related: bug 94468 comment 9

Comment 20

17 years ago
Marking fixed based on earlier comments.  Will vrfy later.
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED

Comment 21

17 years ago
What's with the verify later?
Verified
2002030208/WinXP
Status: RESOLVED → VERIFIED
move...
Component: Europe: West → German
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.