New dark background color for image viewing yields problems (esp. with transparency); needs preference (and UI) to change/switch/customize backdrop color

RESOLVED DUPLICATE of bug 754133

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 754133
6 years ago
4 years ago

People

(Reporter: Leon Sorokin, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:13.0a1) Gecko/20120216 Firefox/13.0a1
Build ID: 20120216031231

Steps to reproduce:

often, transparent PNGs contain black writing which is impossible to read on the dark backdrop which presents itself when viewing image urls.

even worse, there are some magic-wanders out there who produce things like this when trying to remove an image background:

http://blogs.msdn.com/cfs-file.ashx/__key/communityserver-blogs-components-weblogfiles/00-00-01-29-43-metablogapi/2671.ieplrmbp_2D00_image1_2D00_hi_2D00_res_5F00_545FC2B4.png

happy reading!


Actual results:

unreadable text


Expected results:

background color selector built into the viewer. at minimum, black, gray, and white swatches. maybe with the current setting as default. but also changeable by a preference.
(Reporter)

Comment 1

6 years ago
also, maybe checkerboard...
(Reporter)

Updated

6 years ago

Updated

6 years ago
Whiteboard: DUPME

Comment 2

6 years ago
Confirming that there's a usability problem with the new blackground color for image viewing. This definitely needs at least a preference, or, as suggested by reporter, preference plus some kind of UI to change the background color on-demand. Until then, is there any way to tweak this?

What are the next steps to move this bug forward?
OS: Windows 7 → All
Hardware: x86 → All
Summary: dark backdrop for image viewing should be switchable on-demand → New dark background color for image viewing yields problems (esp. with transparency); needs preference (and UI) to change/switch/customize backdrop color

Comment 3

5 years ago
I can confirm that this is an issue over at Wikimedia Commons (file hosting for Wikipedia) where there are many such transparent background PNG files, e.g. https://commons.wikimedia.org/wiki/File:A300Belugav1.0.png .

Comment 4

4 years ago
The particular problem (dark background incompatible with some images) is fixed by bug 754133, but not with an option for other images.  There are, of course, extensions to change the background.
Whiteboard: DUPME → DUPEME

Comment 5

4 years ago
This issue was resolved by bug 754133.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 754133

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.