Global search box shrinks when selected

RESOLVED FIXED in Thunderbird 13.0

Status

Thunderbird
Theme
RESOLVED FIXED
5 years ago
6 months ago

People

(Reporter: andreasn, Assigned: Paenglab)

Tracking

Trunk
Thunderbird 13.0
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Noticed that the search box in trunk shrinks a couple of pixels when selected.
(Assignee)

Comment 1

5 years ago
This is because in unselected state the text is italic (and wider) and when selected normal.
This can be solved by giving a fixed width to the search box, removing the italic (like in Bug 636014) or exchange the flexible spacer with fixed spacer. I'm on XP now and can't test if the last really would solve the problem.
(Assignee)

Comment 2

5 years ago
Created attachment 598397 [details] [diff] [review]
Give a fixed width

With defining the width the box no more jumps when selected. I gave a width of 25em. If needed this width can be adjusted.

When more elements are on the toolbar then the search box adapts the width as before.

The patch also gives a width to the search box on Address book which has the same problem.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #598397 - Flags: review?(nisses.mail)
(Assignee)

Comment 3

5 years ago
Created attachment 599679 [details] [diff] [review]
Give a fixed width

Patch updated after landing of Bug 719008. Now also the search field in Gloda tab shrinks.
Attachment #598397 - Attachment is obsolete: true
Attachment #599679 - Flags: review?(nisses.mail)
Attachment #598397 - Flags: review?(nisses.mail)
(Reporter)

Comment 4

5 years ago
Comment on attachment 599679 [details] [diff] [review]
Give a fixed width

Looks good, functions as expected!
Attachment #599679 - Flags: review?(nisses.mail) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
http://hg.mozilla.org/comm-central/rev/6c1d59144158

Also, please follow the directions below when submitting any future patches to make life easier for the people checking in on your behalf. Thanks!
https://developer.mozilla.org/en/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 13.0
(Assignee)

Updated

6 months ago
Duplicate of this bug: 531131
You need to log in before you can comment on or make changes to this bug.