execCommand breaks the html comment

RESOLVED DUPLICATE of bug 726431

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 726431
6 years ago
6 years ago

People

(Reporter: tomonori.yamada.g+bugzilla, Unassigned)

Tracking

10 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.46 Safari/535.11

Steps to reproduce:

#1
select the "aaaaa" of below
 aaaaabbbbb<!--ccccc-->

#2
excute scrip below
 document.execCommand('forecolor', false, '#ff0000')




Actual results:

string below is displayed on screen.
aaaaabbbbb ccccc

html source is
<span style="color: rgb(255, 0, 0);">aaaaa</span>bbbbb ccccc



Expected results:

string inside html comment should not be displayed like this.
aaaaabbbbb

html source should be 

<span style="color: rgb(255, 0, 0);">aaaaa</span>bbbbb<!--ccccc-->
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 726431
You need to log in before you can comment on or make changes to this bug.