firefox 10 to 10.0.2 creates bad registry keys for ddeexec

RESOLVED DUPLICATE of bug 359630

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 359630
6 years ago
6 years ago

People

(Reporter: kayoss120, Unassigned)

Tracking

10 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

i'm using windows 7. if you have a shortcut to a web page saved to your computer.. when you click on it, error messages come up. this happens every now and then with some versions of firefox since version 2! i am not the only that has noticed the problem. i know how to fix it, but when firefox upgrades, it recreates the problem again. i am going to repost a comment from someone else in 2008. the same problem is back!

Brian   2008-02-08 13:23:46 PDT

This bug is a dupe of so many of the same bugs it is getting crazy. It has
happened for me ever since 2.0.0.0 (maybe before). 

It is most definitely NOT fixed.... Stop closing the bugs as "verified fixed"

Every other dupe (this one included) of this bug suggests deleting the ddeexec
keys from the registry entries below, but this is only a temporary fix. After
your Firefox installation "auto upgrades" it breaks the registry keys again!

The problem is recreated when the upgrade adds the ddeexec keys with the
(default) string value of "%1",,0,0,,,,

To fix (temporary, will break again on update or reinstall), remove the ddeexec
entries from the following keys:

HKCR\HTTP\shell\open
HKCR\htmlfile\shell\open
HKCR\htmlfile\shell\opennew
HKCR\ftp\shell\open
HKCR\gopher\shell\open
HKCR\https\shell\open
HKCR\FirefoxHTML\shell\open
HKCR\FirefoxURL\shell\open

(May be more keys, but this is all I could find so far)

This is a verified issue with both Windows XP and Windows Vista (all versions)

Comment #9 Brian  2008-03-26 12:02:48 PDT

Once again... automatic update to 2.0.0.13 created the ddeexec keys again and
the error message came back. Took a browse through registry and it seems only a
few of the keys were recreated this time though! 

The following keys were recreated this time:
HKCR\FirefoxHTML\shell\open
HKCR\FirefoxURL\shell\open
HKCR\ftp\shell\open
HKCR\gopher\shell\open

So, it seems as if some progress was made, but the underlying issue still
exists.


Actual results:

error message


Expected results:

no error message
duplicate of bug 372016 which is a duplicate of bug 359630
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 359630
You need to log in before you can comment on or make changes to this bug.