Closed Bug 728361 Opened 8 years ago Closed 8 years ago

WebGL getParameter(DEPTH_BITS) returns 0 on some platforms

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bjacob, Assigned: jgilbert)

References

Details

(Whiteboard: webgl-conformance)

Just try it in the Web Console:

var ctx = document.createElement('canvas').getContext('experimental-webgl');
ctx.getParameter(ctx.DEPTH_BITS);

returns 0.

The impl is just forwarding this call to the GL. What might be happening is that since we're not using the main framebuffer of that GL context at all, we don't bother requiring a depth buffer for it at all. So this could be a regression from the switch to FBOs. But really we should keep track of these variables manually, not rely on the GL for that.
Assignee: nobody → jgilbert
Status: NEW → ASSIGNED
GL will get the bits based on the current bound framebuffer.
This was probably a regression from when we were binding to 0 most of the time. However, now, we are properly bound to the correct buffers all the time.

Testing on linux (GLX only uses FBOs) with trunk, I get proper behavior.

bjacob, can you repro this anywhere? Also, this is marked as blocking conformance. Which test is hitting this? Is that test passing or failing now?
Indeed, I can't reproduce anymore.

IIRC this was not hit by a conformance test (whence the webgl-tests-needed).
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: webgl-conformance webgl-test-needed
You need to log in before you can comment on or make changes to this bug.