Last Comment Bug 728392 - "About Nightly" leaks chrome://browser/content/aboutDialog.xul
: "About Nightly" leaks chrome://browser/content/aboutDialog.xul
Status: RESOLVED FIXED
[MemShrink:P2]
:
Product: Toolkit
Classification: Components
Component: Application Update (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla13
Assigned To: Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
:
:
Mentors:
Depends on:
Blocks: leakychrome
  Show dependency treegraph
 
Reported: 2012-02-17 13:26 PST by Olli Pettay [:smaug] (reviewing overload)
Modified: 2012-02-28 10:06 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.27 KB, patch)
2012-02-17 15:51 PST, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
robert.strong.bugs: review+
Details | Diff | Splinter Review

Description Olli Pettay [:smaug] (reviewing overload) 2012-02-17 13:26:13 PST
STR:
Use latest m-c, install cc analyzer from bug 726346.
Open Help->About Nightly
close the About Nightly dialog
load about:cc
click 'Run cycle collector'
Once you see the log, click 'Find Documents'.
JS implemented nsIUpdateChecker seems to keep stuff alive.
Comment 1 Olli Pettay [:smaug] (reviewing overload) 2012-02-17 13:35:14 PST
This is possibly somewhat similar problem as Bug 728230.
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-02-17 15:51:17 PST
Created attachment 598408 [details] [diff] [review]
Patch
Comment 3 Olli Pettay [:smaug] (reviewing overload) 2012-02-17 16:00:59 PST
You probably wanted to ask review from someone.
Comment 4 Loic 2012-02-24 07:47:43 PST
I'm not able to reproduce the leak with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120224 Firefox/13.0a1
Comment 5 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-02-27 17:01:28 PST
Looks pretty good on try: https://tbpl.mozilla.org/?tree=Try&rev=fbddc49d4a36
Comment 6 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-02-28 10:00:41 PST
https://hg.mozilla.org/mozilla-central/rev/cdf2ee308f36

Note You need to log in before you can comment on or make changes to this bug.