need to repeat view coding charset in order to see hebrew letters.

CLOSED DUPLICATE of bug 72847

Status

()

Core
Internationalization
CLOSED DUPLICATE of bug 72847
17 years ago
13 years ago

People

(Reporter: mimi fruchter, Assigned: Erik van der Poel)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)
BuildID:    

When browsing an html file that includes charset windows-1255 (hebrew) by using 
mozilla - you need to activate view-character-coding TWICE in-order to receive 
hebrew display.
 

Reproducible: Always
Steps to Reproduce:
1.you need a hebrew enabled windows 98 installed.
2.use notepad to creat an html file. 
3.use the following example:

<html>
<head>
<meta charset="windows-1255">
  <title>logical hebrew</title>
</head>
<body dir="rtl">
<h1>
--now press alt+rightShift to switch language to hebrew and type--
  gcrh, kudh,
--press alt+RightShift again to switch back to English and type-- 
  </h1>
  </body>
  </html>
4. save the file as logicheb.html
5. browse the file with mozilla
6. compare the result display with the a display of the same file
   browsed with Internet Explorer.
7. press View on the top bar to open a list box
8. choose character coding from list box 
9. choose Hebrew (windows-1255)
10.compare display with IE's display
11.rpeat steps 7-10


Actual Results:  After activating character coding the first time there is no 
change
in display. After repating it will change the display to the one desired for.

Expected Results:  Mozilla should change the display to Hebrew letters after 
first charachter coding. display should natch the one of IE.

When the wrong characters are displayed the full stop at the end of the 
sentence is positioned at the correct location. This changes when you finally 
get the hebrew letter. This will be reported in a separate bug report.
(Assignee)

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 72847 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Closing as duplicate.
Status: RESOLVED → CLOSED
You need to log in before you can comment on or make changes to this bug.