Thunderbird v10 does not resolve DNS

RESOLVED INCOMPLETE

Status

MailNews Core
Networking
--
major
RESOLVED INCOMPLETE
6 years ago
5 years ago

People

(Reporter: WJ, Unassigned)

Tracking

({regression})

x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has protocol logs])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
After updating to v10 (.0.0, .0.1, .0.2) I lost all connectivity. The DNS lookup does not work.

I cannot connect to any servers (private server, google, fastmail). The welcome page after updating doesn't load, with "Problem loading page. Server not found" error. 

I have checked my connections, removed the proxy script and tried three different web connections. There is no firewall. 

I'm running in Safe Mode.  All my other internet progams work fine, including Firefox. 

Rolling back to 9.0.1 reverted things to normal.

Here are some errors from the Error Console: 

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIExternalProtocolService.loadURI]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://messenger/content/mailCore.js :: openFormattedURL :: line 475" data: no] 

Security Error: Content at about:neterror?e=dnsNotFound&u=https%3A//live.mozillamessaging.com/thunderbird/whatsnew%3Flocale%3Den-US%26version%3D10.0.1%26os%3DWINNT%26buildid%3D20120208125618&c=UTF-8&d=live.mozillamessaging.com%20could%20not%20be%20found.%20Please%20check%20the%20name%20and%20try%20again. may not load or link to chrome://global/skin/icons/warning-16.png.
Do you use a third party firewall ?
(Reporter)

Comment 2

6 years ago
I am using a company machine with McAfee Agent v4.0.0 and Check Point Integrity Agent.

The integrity agent has a firewall (I assume, as despite having admin control over everything else, I have no control over these two security applications).

PS I am using Firefox 1.5.0.9.
This is most likely a Firewall issue. You could try to rename thnderbird.exe to for example thunderbird1.exe
Severity: blocker → major
(Reporter)

Comment 4

6 years ago
Tried the rename; no luck.

R.e. the Firefox version. I assume I would have tried Firefox 2, and encountered similar issues. (I'm sorry: I can't remember and I don't have time to test right now.)

Was there a fundamental change to dns lookups or internet access for TB 10 and FF 2 ?
there was no fundamental change. The only reported issue with had in all these years are caused by firewalls.
(Reporter)

Comment 6

6 years ago
Then this is interesting then. I'll stay on 9.0.1 for the moment. Are there any significant security issues (fixed in v10) not to do so?

Do you see a way of seeing what is going on? Is there a security or web log somewhere in the executibles?

I've never contributed, but I guess I could build the code and go into debug mode. What language is the source code in?
for the fixed security bugs fixed see http://www.mozilla.org/security/known-vulnerabilities/

You could create a NSPR log https://developer.mozilla.org/en/HTTP_Logging (you want nsHostResolver:5) but you will not see much if a firewall blocks requests.

>What language is the source code in?
Gecko is c, c++
(Reporter)

Comment 8

6 years ago
Created attachment 598540 [details]
NSPR_LOG_FILE nsHostResolver:5

This is the NSPR_LOG_FILE with NSPR_LOG_MODULES=nsHostResolver:5
I have just updated TB and this is generated during start-up.

Comment 9

6 years ago
Have you enabled Offline mode accidentally inside TB?

The firewall remark by other commenters means that if you have a personal firewall that allows connection to the network by application, it may have noticed the change in the TB executable (as it was upgraded) and needs to ask you for permission to allow it to the net again. Maybe you didn't allow it by mistake, or it didn't ask and decided to block TB. Can you check the settings of the firewall (it's list of blocked/allowed apps)?
Ok for what I've seen in the log, dns is resolved - but I don't see any attemps to resilve google , fastmail and friends.

Updated

6 years ago
Keywords: regression

Comment 11

5 years ago
reporter hasn't replied to comment 9
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Component: General → Networking
Product: Thunderbird → MailNews Core
Resolution: --- → INCOMPLETE
Whiteboard: [has protocol logs]
(Reporter)

Comment 12

5 years ago
Sorry I didn't reply.
The issue "magically" went away after a certain period. I conclude that the issue was indeed a firewall one, but this cannot be confirmed. I never logged into the company VPN to allow an update to the security strategy. I therefore have no idea whether there was a change on the firewall side, or on the application side.

PS No, I didn't have off-line mode on. No, it wasn't an acceptance issue for a personal firewall, as it is a company machine (i.e. one of many many thousands) which provides no access to firewall details or allows user input into an update.

I reiterate the clients (McAfee Agent v4.0.0 and Check Point Integrity Agent) for any future unfortunate ppl with admin access to install programs on a company machine, but no access to firewall information.
You need to log in before you can comment on or make changes to this bug.