If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

After loading a page to about:newtab tab, about:newtab document stays in memory

RESOLVED DUPLICATE of bug 728577

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 728577
6 years ago
6 years ago

People

(Reporter: smaug, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
After loading a page to about:newtab tab, about:newtab document stays in memory.
Looks like it is released after loading some new page to the tab.

str:
Open FF.
Open a new tab (it should have about:newtab loaded)
Click some link in the page
Run cycle collector, check cc log. about:newtab is there.
(bug 728407#c0 can be useful)
If I click a link further about:newtab disappears.

See also bug 724239. Is it maybe held alive by the bfcache or something? I thought the bfcache sometimes freezes windows and sometimes throws them away.
(Reporter)

Comment 2

6 years ago
Yeah, clicking further makes it disappear.
Based on the cc log 0x7fab53fd6740 [rc=6] root nsGenericElement (xhtml) a class='site' about:newtab
is the root.
IIRC bfcache doesn't have pointers to elements, but to document.
Also, bfcached documents are "in CC generation", so CC doesn't traverse them at all.
(Reporter)

Comment 3

6 years ago
This could be related to bug 728426, where a document is also kept alive temporarily.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 728577
No longer blocks: 728407
You need to log in before you can comment on or make changes to this bug.