If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Rendering issue with Camino on Mac

VERIFIED DUPLICATE of bug 728557

Status

Camino Graveyard
General
VERIFIED DUPLICATE of bug 728557
6 years ago
6 years ago

People

(Reporter: Sunil, Unassigned)

Tracking

1.9.2 Branch
x86
Mac OS X

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 598532 [details]
Differences-In-Rendering.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_2) AppleWebKit/534.52.7 (KHTML, like Gecko) Version/5.1.2 Safari/534.52.7

Steps to reproduce:

Kindly check this https://bugzilla.mozilla.org/show_bug.cgi?id=728557. Creating a separate bug for Camino.

On Camino, the behavior is slightly different.

1. Launch camino.
2. Type "ಕೋ" in URLBar, SearchBar and text box.


Actual results:

The rendering in URLBar and SearchBar are correct.


Expected results:

Rendering should be consistent.

Comment 1

6 years ago
From the other bug, it sounds like this might be a font issue. Are Safari and Chrome using the exact same font in all three places?
(Reporter)

Comment 2

6 years ago
Yes, Safari and Chrome are using the same font (Apple's Kannada Sangam MN.ttf). Its the default font that comes with Mac OS X Lion.

As I said earlier, rendering on URLBar and SearchBar are correct, however rendering in webpage is incorrect.

Comment 3

6 years ago
Let me ask it again: Are Safari and Chrome using the exact same font *in all three places*?

In other words, is the font in the Google search field the exact same font that's used in both the location and search bars?
(Reporter)

Comment 4

6 years ago
>> Are Safari and Chrome using the exact same font *in all three places*?
Yes.

Additional Info
In Firefox, rendering issue could be noticed in all three places.
In Camino, rendering issue is present only in webpage.

The font used by Firefox/Camino/Safari/Chrome in all three places were same.

Comment 5

6 years ago
Camino, like Firefox. uses the Gecko rendering engine. The reason the behavior is the same is because it's the same engine, so there's no need for two bugs.

(Camino has native chrome, Firefox uses Gecko to render its chrome, thus the difference there.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 728557

Updated

6 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

6 years ago
>> (Camino has native chrome, Firefox uses Gecko to render its chrome, thus the difference there.)

Thanks for the explanation.
You need to log in before you can comment on or make changes to this bug.