mozilla displays "alt" tag text on this page, other browsers don't

VERIFIED INVALID

Status

()

VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: graham.knap, Assigned: clayton)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
BuildID:    2001032015

When viewing this page in Mozilla, you will see in the top corner of the body
text, right above the "USA" headline:

spacer.gif (43 bytes)
spacer.gif

Having looked at the page source, this text comes from the ALT attributes for a
couple of images... which don't seem to exist at the server.

I'm not sure what the correct behaviour should be... but the page looks much
cleaner in Netscape 4.72, where the ALT text does not get displayed.

Reproducible: Always
(Reporter)

Comment 1

18 years ago
sorry, i forgot to mention OS=linux... though I somehow doubt it will matter.
(Reporter)

Comment 2

18 years ago
same results on win32 build 2001031604 -- alt tag text is shown.
note also that ie5, like netscape, also does not display the alt text.
If an image is not available or is disabled or is otherwise broken, then it 
should be replaced by its alternative text. See bug 1994.

INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
Verified. From http://www.w3.org/TR/html4/struct/objects.html#adef-alt

"Do not specify irrelevant alternate text when including images intended to
format a page, for instance, alt="red ball" would be inappropriate for an image
that adds a red ball for decorating a heading or paragraph. In such cases, the
alternate text should be the empty string (""). Authors are in any case advised
to avoid using images to format pages; style sheets should be used instead."
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.