If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla has a big memory leak after it's opened and closed at least 5 times

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
17 years ago
12 years ago

People

(Reporter: Jorden van der Elst, Assigned: asa)

Tracking

({mlk, perf})

Trunk
x86
Windows ME
mlk, perf

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; 0.8.1) Gecko/20010316
BuildID:    Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; 0.8.1) Gecko/20010316

The past couple of Mozilla builds I tried have the same memory leak problem that
Netscape 4.7x had. Open, use and close Mozilla at least 5 times, and the 6th
time it won't start when you need it. You need to reboot your PC to get it to
work again, otherwise it will just start in the background. 


Reproducible: Always
Steps to Reproduce:
1. Open Mozilla
2. Use Mozilla to surf
3. Close Mozilla

repeat this 4 times. Might be more on a testPC.

Actual Results:  Mozilla starts normal all 5 times, and closes normal.

On the 6th time trying to open it, I see my mouse-cursor with the hourglass next
to it, but no Mozilla flash screen opening, nor will the Java icon load in the
systemtray. Upon pressing CTRL+ALT+DELETE, I see Mozilla in the list of started
programs. Have to cancel it from there to get rid of it. And reboot to get
Mozilla working again.

Expected Results:  No matter how many times I open or close the browser, it
should always work. I don't want to reboot my PC every half a day to be able to
get my email, or surf to my favorite sites.

Updated

17 years ago
Keywords: mlk, perf
(Assignee)

Comment 1

17 years ago
Jorden, what makes you think this is a memory leak?  It sounds to me like on
that 5th attempt Mozilla is not exiting completely. I'm not sure how you've made
the connection between Mozilla's failure to shut down and this memory leak
you're reporting.  Can you check before trying to start Mozilla that 6th time
and see if mozilla.exe is still running. 
(Reporter)

Comment 2

17 years ago
I've checked. It's not running after I shut it down the 5th time. At least, not
in the visible programs running in the box that opens after pressing CTRL+ALT+DEL
However, when I do start one or more instances of Mozilla (6, 7 8 etc.) they do
show in that box, with no Mozilla starting up.

I called it memory leak, as it is using up a lot of memory each time. Between 30
and 60Mb per Mozilla window opened, and it only gives back around 15Mb upon closing.

Comment 3

17 years ago
Still a problem in the latest nightlies?
(Reporter)

Comment 4

17 years ago
Yes, I still have the same problem in the latest nightlies. Although not really 
after a 5th time starting up, I cannot start Mozilla after my PC's been on for 
say 4 hours, and I have used Mozilla once.
I'm using 20012504 at this time.

Comment 5

17 years ago
WORKSFORME: Win2k 2001050204-Trunk: Unfortunately that doesn't accomplish much,
since WinNT/2k/XP use a totally different Memory Management bug than do the
Win9x builds.

Back in My WindowsME days, I saw this problem as well, but for me it was a
simple case of Mozilla failing to exit completely.

Reporter: Try this. Grab a copy of Wintop
(http://www.microsoft.com/windows95/downloads/contents/wutoys/w95kerneltoy/) and
install it. This will show all the processes on your system and ensure that it
isn't still running "Hidden" on your system.
(Reporter)

Comment 6

17 years ago
Nightly Build 20011005 still has the same problem.

Btw Ken, thanks for the Wintoys. They come to good use.

Comment 7

17 years ago
I can't reproduce it.  2001051704 on Win98.

Comment 8

17 years ago
I can't reproduce this neither.  Using B2001051804, WinME
reporter: is this a dupe of bug 63383 ?

WFm with win2k build 20010519.. (CVS)
(Reporter)

Comment 10

17 years ago
Matti, it might be a dup for the thread you pointed to.
Although I never thought of checking my system resources, one thing I will be
checking from now on.

I'm running with 256Mb PC-100 RAM, and resources don't drop below 60% most of
the time. The one thing running on this system is genome@home, 24/7

Comment 11

17 years ago
Works for me as well. Win98, 196MB RAM. Closed and started up to 14 consecutive
times, no problems. Why not 15? Confucious say so. Can't reproduce. Latest
nightly as of May 30 2001. Build ID 2001053004
This could have been caused by bug 53952 if Mozilla was indeed failing to exit 
completely.  Jorden, could you please retest with a recent build?
(Reporter)

Comment 13

17 years ago
Testing it with Build ID: 2001060104. So far so good. Looks like It's been
repaired, but I'm still testing it. Don't close the bug thread yet.

Opened this Moz 10 times now, without much problems, but for a steadily
descending resources meter (now at 60%)

Jorden.
(Reporter)

Comment 14

17 years ago
Ah, got the first error... Mozilla was closed due to error in <unknown>
(Reporter)

Comment 15

17 years ago
woohoo !!

I've been playing games all weekend long and it seems as if this lates build I
am using has no other problem that the one above.
The memory leak is gone!!

I even tried opening Moz with 50% resources, and it worked !!

I'll close this thread for now :-))

Jord.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.