android.database.CursorIndexOutOfBoundsException: After last row. at android.database.MatrixCursor.get(MatrixCursor.java:73)

VERIFIED FIXED

Status

()

P1
critical
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({crash, regression, topcrash})

13 Branch
ARM
Android
crash, regression, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash], crash signature)

(Reporter)

Description

7 years ago
It's #5 top crasher over the last 3 days.
It first appeared in 13.0a1/20120216 and has been hit by 6 different users.

android.database.CursorIndexOutOfBoundsException: After last row.
	at android.database.MatrixCursor.get(MatrixCursor.java:73)
	at android.database.MatrixCursor.getInt(MatrixCursor.java:244)
	at org.mozilla.gecko.AwesomeBarTabs$AwesomeCursorViewBinder.setViewValue(AwesomeBarTabs.java:189)
	at android.widget.SimpleCursorTreeAdapter.bindView(SimpleCursorTreeAdapter.java:220)
	at android.widget.SimpleCursorTreeAdapter.bindGroupView(SimpleCursorTreeAdapter.java:264)
	at android.widget.CursorTreeAdapter.getGroupView(CursorTreeAdapter.java:208)
	at android.widget.ExpandableListConnector.getView(ExpandableListConnector.java:445)
	at android.widget.AbsListView.obtainView(AbsListView.java:1430)
	at android.widget.ListView.makeAndAddView(ListView.java:1836)
	at android.widget.ListView.fillDown(ListView.java:670)
	at android.widget.ListView.fillFromTop(ListView.java:727)
	at android.widget.ListView.layoutChildren(ListView.java:1675)
	at android.widget.AbsListView.onLayout(AbsListView.java:1260)
	at android.view.View.layout(View.java:7278)
	at android.widget.FrameLayout.onLayout(FrameLayout.java:338)
	at android.view.View.layout(View.java:7278)
	at android.widget.LinearLayout.setChildFrame(LinearLayout.java:1254)
	at android.widget.LinearLayout.layoutVertical(LinearLayout.java:1130)
	at android.widget.LinearLayout.onLayout(LinearLayout.java:1047)
	at android.view.View.layout(View.java:7278)
	at android.widget.FrameLayout.onLayout(FrameLayout.java:338)
	at android.view.View.layout(View.java:7278)
	at android.widget.LinearLayout.setChildFrame(LinearLayout.java:1254)
	at android.widget.LinearLayout.layoutVertical(LinearLayout.java:1130)
	at android.widget.LinearLayout.onLayout(LinearLayout.java:1047)
	at android.view.View.layout(View.java:7278)
	at android.widget.FrameLayout.onLayout(FrameLayout.java:338)
	at android.view.View.layout(View.java:7278)
	at android.widget.FrameLayout.onLayout(FrameLayout.java:338)
	at android.view.View.layout(View.java:7278)
	at android.view.ViewRoot.performTraversals(ViewRoot.java:1172)
	at android.view.ViewRoot.handleMessage(ViewRoot.java:1939)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:143)
	at org.mozilla.gecko.GeckoApp$34.run(GeckoApp.java:1807)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:143)
	at android.app.ActivityThread.main(ActivityThread.java:4196)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:507)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:839)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:597)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=android.database.CursorIndexOutOfBoundsException%3A%20After%20last%20row.%20at%20android.database.MatrixCursor.get%28MatrixCursor.java%29
mentioned in bug 728384; possibly related to that bug

I hit this bug following these steps: 
1. sync account
2. while the sync is going; go to the awesome page
3. tap on top sites, tap on bookmarks, tap on history
4. tap back on top sites
5. tap on awesome bar.

Comment 2

7 years ago
We're getting rid of that MatrixCursor in bug 722020, so this crash should go away.
(Reporter)

Updated

7 years ago
Depends on: 722020

Updated

7 years ago
Priority: -- → P1
Ran into this bug for the 2/23 build, but that is before the fix for bug 722020.

Comment 4

7 years ago
Marking this as FIXED, since this code is gone.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Tried to repro this crash, seems fixed.  Nightly 2/27/2012, Samsung Galaxy S II
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.