567920 byte leak on Linux

CLOSED FIXED

Status

SeaMonkey
General
--
critical
CLOSED FIXED
17 years ago
13 years ago

People

(Reporter: Edward Kandrot, Assigned: Edward Kandrot)

Tracking

({mlk})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
Leak appeared about 12 days ago.  I am posting the data here from the current 
leak log.  I am unsure who to assign it to, so please re assign as needed.

CSSDeclarationImpl                            68800       0.00%
nsCSSSelector                                 58284       0.00%
nsXULPrototypeElement                         42816       0.00%
nsStr                                         38300       0.00%
....  (see attachement for the rest)
(Assignee)

Comment 1

17 years ago
Created attachment 28412 [details]
Leak Log Text

Comment 2

17 years ago
for the past day i've been seeing this when i close mozilla:
"Runtime mismatch, so leaking context!"
Just upgraded Xfree86 here, but would affect it? Rebuilt moz just now, same msg.

Comment 3

17 years ago
Forget that. I didn't make clean.

Updated

17 years ago
Keywords: mlk, perf

Comment 4

17 years ago
Marking NEW as per comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

17 years ago
looke like imagelib to me. anywhere is better than Browser General.
Assignee: asa → pavlov
Component: Browser-General → ImageLib
QA Contact: doronr → tpreston

Comment 6

17 years ago
this "looks like imagelib"  how do you see that?

Comment 7

17 years ago
reassigning to asa since he appears to understand this bug.
Assignee: pavlov → asa
Component: ImageLib → Browser-General
kandrot@netscape.com: 
Is this still a problem or can we close this ?

Comment 9

17 years ago
clearly it's imagelib because that's what decided to leak less.

kandrot: you should know better than to leave a bug in browser-general. in the 
immortal words of a card game whose rules and name i cannot disclose 'keep it 
it's yours'
Assignee: asa → kandrot
Keywords: perf
(Assignee)

Comment 10

17 years ago
timeless:

Based on the comment 2 above yours:
"------- Additional Comments From Stuart Parmenter 2001-04-16 16:54 -------

reassigning to asa since he appears to understand this bug."

it would appear that your comments are unwarranted.  Please read all of the
comments before commenting and blaming someone.  Please refrain from assigning
bugs to other people if you are unaware of the issues; I did not need this bug
assigned to me to fix, since I had nothing to do with it.  Thanks.

all:

It appears that this bug should be closed.  Since I did not do anything to fix
it, and whoever did is not taking credit for fixing it, I will mark it fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

17 years ago
Since I filed it, and it was assigned to me to close, and I can not close it
without a comment, this is it.
Status: RESOLVED → CLOSED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.