Thunderbird Update fails and gets redownloaded over and over again

RESOLVED WORKSFORME

Status

()

Toolkit
Application Update
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: Johannes Linke, Unassigned)

Tracking

10 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
When starting thunderbird, i got the UAC-message asking for administrator rights for thunderbird. i cklicked yes, then thunderbird said "update could not be installed. please make sure no other thunderbird process are active on this computer. then restart thunderbird to try again" (translated). then thunderbird started normally.

at the next start it did not ask for administrator rights, but showed a larger window:
"when trying to check for updates, download or install them, problems occurred. thunderbird could not be updated for the following reason: the update could not be installed (patch-application failed). you can try to update thunderbird manually...." (translated)

after closing that window and clicking the help menu item, thunderbird redownloads the update.

i repeated the whole process about three times now.
(Reporter)

Updated

6 years ago
Component: General → Installer
(Reporter)

Comment 1

6 years ago
i forgot: current version is 10.0
the update it downloads is 19.8 Mbyte big.
(Reporter)

Updated

6 years ago
Summary: Update fails, redownloads it, still fails → Update fails and gets redwonloaded over and over again
(Reporter)

Updated

6 years ago
Summary: Update fails and gets redwonloaded over and over again → Update fails and gets redownloaded over and over again
QA Contact: general → installer

Comment 2

6 years ago
(In reply to Johannes Linke from comment #1)
See bug 340535.
Also, I remember having a similar problem (failure to update), it turned out that there was not enough hard disk space for the update.
There is an update.log file in your profile folder, what does the log file contains ?
(Reporter)

Comment 4

6 years ago
SOURCE DIRECTORY C:\Users\Johannes\AppData\Local\Thunderbird\Mozilla Thunderbird\updates\0
DESTINATION DIRECTORY C:\Program Files (x86)\Mozilla Thunderbird
NS_main: file in use - failed to exclusively open executable file: C:\Program Files (x86)\Mozilla Thunderbird\thunderbird.exe
(Reporter)

Comment 5

6 years ago
sorry, again i forgot something: there is no other thunderbird instance running.
(In reply to Johannes Linke from comment #5)
> sorry, again i forgot something: there is no other thunderbird instance
> running.

can you check in the task manager ?
Component: Installer → Application Update
Product: Thunderbird → Toolkit
QA Contact: installer → application.update
Version: 10 → 10 Branch
(Reporter)

Comment 7

6 years ago
i did, there is only one thunderbird.exe running. i also searched for open handles on thunderbird.exe with the process explorer, but there was no handle from another process. (i checked it when the small "update failed"-window showed up)

Comment 8

3 years ago
Johannes, do you still see this problem?
Flags: needinfo?(johannes.linke)
Summary: Update fails and gets redownloaded over and over again → Thunderbird Update fails and gets redownloaded over and over again
(Reporter)

Comment 9

3 years ago
i did not see it ever since i reported it, i guess i must have done a manual installation to solve it.
Flags: needinfo?(johannes.linke)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.