Google searches for certain term fail due to UA change

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

({qawanted})

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
I've been having certain Google searches fail, reliably, using Nightly and my usual profile. Couldn't reproduce with a new profile, until I realized the problem only happen when you're logged into Google.

STR:

1) Create new profile
2) Log into Google (https://accounts.google.com)
3) Perform a search with any of the following words: plugin, firefox, browser
4) Receive a Google error page:

"Server Error
The server encountered an error and could not complete your request.

If the problem persists, please mail error@google.com and mention this error message and the query that caused it."

Presumably something in Google's all-knowing-all-seeing backend is interested in certain Firefox (?) related search terms, gets confused by the UA, and fails in a spectacular and surprisingly catastrophic fashion.

Doesn't matter where the search originates from (search bar, start page, google.com), and even following simple links like "https://www.google.com/search?q=firefox" result in an error page.

Works fine with a Nightly from the 16th, before the UA change in from bug 588909 landed.

The following values for general.useragent.override (in the working nightly) will cause it to start failing:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:13.0) Gecko/13.0a1 Firefox/13.0a1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:13.0) Gecko/13.0 Firefox/13.0a1
(In reply to Justin Dolske [:Dolske] from comment #0)
> Doesn't matter where the search originates from (search bar, start page,
> google.com), and even following simple links like
> "https://www.google.com/search?q=firefox" result in an error page.

WFM
Assignee: nobody → english-us
Component: Networking: HTTP → English US
Depends on: 651674
Keywords: qawanted
Product: Core → Tech Evangelism
QA Contact: networking.http → english-us
Version: Trunk → unspecified
(In reply to Dão Gottwald [:dao] from comment #1)
> WFM

I can reproduce when I use the current Nightly build's default user agent string.

When I spoof back to the Firefox 10.0.1 UA string, the search loads normally.

Comment 3

7 years ago
I get the error with https://www.google.com/search?q=spdy but only when I'm logged in.
None of these searches trigger it over here. :(
I'm logged in, I don't get redirected or anything like that.
(Reporter)

Comment 5

7 years ago
Created attachment 599026 [details]
Screenshot of error

Screenshot for those missing out on the fun.

Also noticed "goo" triggers it (I accidentally manage to search for this about once a week by mistyping "google" :-).
(In reply to Dão Gottwald [:dao] from comment #4)
> None of these searches trigger it over here. :(
> I'm logged in, I don't get redirected or anything like that.

If it makes you feel any better, I can only reproduce this with the "firefox" search. "spdy" and "goo" work correctly for me...
I can see the error for "firefox" "goo" "spdy" plus "mozilla" and "opera".

"msie" is not a problem.

:)

(I also confirmed the result is the same over spdy or http/1 - so that isn't related)
(Reporter)

Comment 8

7 years ago
It's a fun new game. I ran through a bunch of stream-of-conscious words...

Terms that work: Dão, Wes, Asa, privacy, chrome, chromium, bacon, monopoly, lawyers, kittens, puppies, public, classified, security, malware, virus, search, larry, oranges, press, journalist, spaceship, ufo, roswell, majestic, conspiracy, kennedy, reagan, bush, clinton, carter, defense, keyhole, nuclear, terrorist, bomb, gps, trident, dsp, illuminati, templar, fnord, cia, nsa, dsa, nima, castro, landings, svn, cvs, rcs, mxr, dxr, monkey, ionmonkey, contract, shoes, boot, gecko, maimo, meego, nokia, samsung, htc, sprint, verizon, fiber, wimax, osx, cupertino, palo, alto, jose, francisco, vancouver, pickerington, washington, pipa, house, senate, obama, doj, justice, army, force, marines, coast, guard, navy, tank, bmw, ecto, flash, salt, nacl, pepper, bing, ddg, central, birch, philor, star, images, news, beer, whisky (no e!), moonshine, asbestos, viagra, green, card, id, cigar, drugs, pills, catnip, lard, tallow, pepsi, dew, sprite, crush, tea, cappuccino, americano, frappuccino, iced, starbucks, grande, venti, calories, caffeine, taco, burrito, pollo, asado, cheese, beans, tortilla, foil, pork, chicken, soy, bbq, multimeter, atmel, pic, capacitor, inductor, diode, zombie, vampire, football, soccer, baseball, racing

Terms that fail: Jesse, Dolske, Aza, eich, Bugzilla, fraud, cookies, antitrust, microsoft, goats, secret, toolbar, sergey, page, brin, steve, apples, banana, satellite, mercurial, git, static, jit, terms, details, mobile, android, webos, linux, view, san, toronto, moncton, sopa, fbi, air, java, google, aurora, nightly, tbpl, plus, whiskey (with e!), wine, coke, coffee, latte, bell, carnitas, beef, arduino, resistor, solder, soldier, horror, music, album
All WFM, win7 x64 m-c build based on cset:
http://hg.mozilla.org/mozilla-central/rev/b8e7474374d5

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/13.0a1 Firefox/13.0a1
This happened to me too on numerous occasions. Nightly after bug 588909 only.

Comment 11

7 years ago
It has been noted in bug 651674 comment 63 (and onwards) that that bug appears to be fixed now. I also cannot reproduce this bug.

Can anyone here (Justin and others) reproduce this bug when making the proposed change to the user agent string?

Steps:

1. Go to about:support and copy the user agent string
2. Go to about:config and add a new string: general.useragent.override and paste in the current UA.
3. Replace Gecko/yyyyMMdd with Gecko/14.0 (proposed change)
4. Replace Firefox/14.0a1 with Firefox/14.0 (this happens during Beta anyway)
5. Test your local Google homepage and search results page, both logged in and logged out.
6. Report any brokenness or lack of usual features.

Comment 12

7 years ago
Mike, this was a bug that people were hitting whilst the proposed change was on trunk (see screenshot). When logged in, certain searches caused errors.

I can't reproduce it now with those same changes, either logged in or out. Did anything specifically change to fix this is it just a side-effect of something else?

Fx 14 UA without proposed change (plaform and architecture obviously varies):

Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20100101 Firefox/14.0

With proposed change:

Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/14.0 Firefox/14.0

Can you check that both of those versions will work OK from Google's side of things?

(Although probably it would be changed at the start of the next cycle for maximum testing time, so Fx 15 would be the first release to have it).
Bug 588909 relanded. Please report back whether or not you see this bug again, starting with tomorrow's nightly.

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.