Allow automatic switch_to_frame for Marionette tests

RESOLVED DUPLICATE of bug 800320

Status

Testing
Marionette
RESOLVED DUPLICATE of bug 800320
6 years ago
6 years ago

People

(Reporter: mdas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Allow something like

MARIONETTE_LAUNCH_GAIA_APP_SWITCH

Which will launch the application and switch your context to be within the launched app instead of running the test from within the homescreen's frame. It will make testing and getting elements a bit easier.
edit:
MARIONETTE_LAUNCH_GAIA_APP_SWITCH = "../sms/sms.html"; //need to specify the app to launch, of course
dupe of bug 800320?
Yeah, I think we can consider it a dupe.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 800320
You need to log in before you can comment on or make changes to this bug.