Privacy violation: cookies not cleared on shutdown

RESOLVED DUPLICATE of bug 443354

Status

()

defect
RESOLVED DUPLICATE of bug 443354
8 years ago
7 years ago

People

(Reporter: dieter, Unassigned)

Tracking

10 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120216082320

Steps to reproduce:

Preferences->Privacy settings tell firefox to delete cookies on shutdown
Preferences->General tells firefox to continue the last session
firefox shutdown
firefox restart


Actual results:

The previous session was continued but the cookies from before the shutdown were still there.


Expected results:

Cookies should have been cleared.

Clearing cookies on shutdown works, when a new session is started. Apparently, firefox binds the cookie lifetime to the session not the shutdown. One might think this as a feature. But, the current behaviour is at least inconsistent (HTTP login information is cleared on shutdown, the preferences text promisses to clear on shutdown not on session end) and it can lead to privacy violation. At least, it should be controllable.
The bug may be related to https://bugzilla.mozilla.org/show_bug.cgi?id=450850.

However, in my case, the behaviour is not related to an old plugin as everything works fine when a new session is started.
Do cookies from sites visited after setting the Privacy setting get deleted at shutdown?
If yes, and only older cookies are remembered, this is a duplicate of bug 530594.
Component: Untriaged → Session Restore
QA Contact: untriaged → session.restore
No cookies get deleted at shutdown -- neither old nor new ones. All cookies get deleted when the session is discontinued (at restart, firefox asks whether a new session should be started (i.e. the old one discontinued) or whether the old session should be continued; cookies are deleted in the first case and not deleted in the second case).
Can you confirm I got the steps right?

1. Start Firefox.
2. Set the following options: Privacy ---> Accept cookies from sites-Until i Close Firefox, General --->When Firefox starts-->show my windows and tabs from last time.
3. Visit some pages. (cookie list gets populated)
4. Interrupt the Firefox session (so that restore session appears at startup)
5. Select Restore.
(In reply to Virgil Dicu [:virgil] [QA] from comment #4)
> Can you confirm I got the steps right?
> 
> 1. Start Firefox.
> 2. Set the following options: Privacy ---> Accept cookies from sites-Until i
> Close Firefox, General --->When Firefox starts-->show my windows and tabs
> from last time.
> 3. Visit some pages. (cookie list gets populated)
> 4. Interrupt the Firefox session (so that restore session appears at startup)
> 5. Select Restore.

You got them right. To be explicit, I would describe 4. as "close Firefox" (to stress that after the "close", cookies should be deleted).
This is intentional and established behavior for Firefox. Cookies for your open tabs are restored by session restore (they are cleared from the cookie database at shutdown, session restore just restores some).

You may also be interested in bug 530594.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 443354
You need to log in before you can comment on or make changes to this bug.