Closed Bug 729076 Opened 13 years ago Closed 13 years ago

indexeddb continue should allow duplicate indexes

Categories

(Core :: Storage: IndexedDB, defect)

defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: odinho, Unassigned)

References

Details

User Agent: Opera/9.80 (X11; Linux x86_64; U; en) Presto/2.10.229 Version/11.61

Steps to reproduce:

Add { pk: 1, name: "Ada" }
Add { pk: 2, value: "Lisa" }
Add { pk: 3, value: "Lisa" }

have an index("value")

index.openCursor()

iterating that:

pk: 1, Ada -> cursor.continue('Lisa')
pk: 2 , Lisa-> cursor.continue('Lisa') // Throws!


Actual results:

Throws where it shouldn't.


Expected results:

Should go to

pk: 3, Lisa-> cursor.continue()
null
Blocks: IndexedDB
Component: DOM: Core & HTML → DOM
OS: Linux → All
Hardware: x86_64 → All
Passing an argument to .continue() is intended when you want to skip forward to the first entry with a given key.

If you simply want to get the next entry just call .continue() without providing any arguments.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
Component: DOM → DOM: IndexedDB
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.