Closed Bug 729082 Opened 11 years ago Closed 11 years ago

MAPLE - Jerky panning

Categories

(Firefox for Android Graveyard :: General, defect, P1)

ARM
Android
defect

Tracking

(blocking-fennec1.0 beta+)

RESOLVED DUPLICATE of bug 734164
Tracking Status
blocking-fennec1.0 --- beta+

People

(Reporter: aaronmt, Unassigned)

References

Details

(Keywords: perf, Whiteboard: MAPLE mwc-demo [gfx])

Panning is jerky and more noticeable than trunk mozilla-central builds.

Tested via panning the URL: http://androidandme.com

--
Latest Maple Android (02/21)
Samsung Galaxy Nexus (Android 4.0.2)
Mozilla/5.0 (Android; Mobile; rv:13.0) Gecko/13.0 Firefox/13.0a1
When I pan the frame-rate ranges between 1FPS~20FPS. I expected ~60FPS.
Testcase here:
With Aurora I get as result: 12887ms
With Maple I get as result: 22961ms.
This is on the Samsung Galaxy Nexus, Android 4.0.2.
Whiteboard: maple
Priority: -- → P1
Needs assignee.
Whiteboard: maple → MAPLE mwc-demo
Some more testcases here (regarding scrolling) that seem to be slower with Maple: http://people.mozilla.org/~mwargers/tests/performance/
The solution to this is probably incremental texture upload and SurfaceTexture on ICS. I'm not very bullish on gralloc at the moment, except as a last resort if we can't satisfactorily work around the GPU bugs blocking incremental texture upload.
blocking-fennec1.0: --- → beta+
Depends on: 730718
Much better with bug 732013.
No longer blocks: land-maple
Depends on: 732917
Whiteboard: MAPLE mwc-demo → MAPLE mwc-demo [gfx]
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #5)
> Some more testcases here (regarding scrolling) that seem to be slower with
> Maple: http://people.mozilla.org/~mwargers/tests/performance/

Martijn - Can you run the tests again on Aurora and Nightly. Also try running it on Stock and Chrome too. Thanks.
Samsung Galaxy Nexus used for testing
http://people.mozilla.org/~mwargers/tests/performance/textscrolling.htm
Aurora build (from 4-2): 13651ms
Nightly build (from 4-2): 33257ms
Stock browser: 4200ms
Chrome Beta: 4285ms

http://people.mozilla.org/~mwargers/tests/performance/dottedborderscrolling_moredots.htm
Aurora build (from 4-2): 78102ms
Nightly build (from 4-2): 54629ms
Stock browser: 4163ms
Chrome beta: 4166ms (but Chrome beta doesn't seem to render the side borders)

http://people.mozilla.org/~mwargers/tests/performance/361754_bad_scrolling_largebackground.htm
Aurora build (from 4-2): 38733ms
Nightly build (from 4-2): 11098ms
Stock browser: 8248ms
Chrome beta: 8733ms
Keywords: qawanted
Duping because there is little independent value in this bug anymore.
Status: NEW → RESOLVED
Closed: 11 years ago
No longer depends on: 734164
Keywords: qawanted
Resolution: --- → DUPLICATE
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #10)
> Samsung Galaxy Nexus used for testing
> http://people.mozilla.org/~mwargers/tests/performance/textscrolling.htm
> Aurora build (from 4-2): 13651ms
> Nightly build (from 4-2): 33257ms
> Stock browser: 4200ms
> Chrome Beta: 4285ms
> 
> http://people.mozilla.org/~mwargers/tests/performance/
> dottedborderscrolling_moredots.htm
> Aurora build (from 4-2): 78102ms
> Nightly build (from 4-2): 54629ms
> Stock browser: 4163ms
> Chrome beta: 4166ms (but Chrome beta doesn't seem to render the side borders)
> 
> http://people.mozilla.org/~mwargers/tests/performance/
> 361754_bad_scrolling_largebackground.htm
> Aurora build (from 4-2): 38733ms
> Nightly build (from 4-2): 11098ms
> Stock browser: 8248ms
> Chrome beta: 8733ms

These are all measuring painting performance because the scrolling is driven by content script instead of happening asynchronously. They should probably all be separate bugs.
No longer blocks: nativefennecgllayers
(In reply to Jeff Muizelaar [:jrmuizel] from comment #12)
> (In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #10)
> > Samsung Galaxy Nexus used for testing
> > http://people.mozilla.org/~mwargers/tests/performance/textscrolling.htm
> > Aurora build (from 4-2): 13651ms
> > Nightly build (from 4-2): 33257ms
> > Stock browser: 4200ms
> > Chrome Beta: 4285ms
> > 
> > http://people.mozilla.org/~mwargers/tests/performance/
> > dottedborderscrolling_moredots.htm
> > Aurora build (from 4-2): 78102ms
> > Nightly build (from 4-2): 54629ms
> > Stock browser: 4163ms
> > Chrome beta: 4166ms (but Chrome beta doesn't seem to render the side borders)
> > 
> > http://people.mozilla.org/~mwargers/tests/performance/
> > 361754_bad_scrolling_largebackground.htm
> > Aurora build (from 4-2): 38733ms
> > Nightly build (from 4-2): 11098ms
> > Stock browser: 8248ms
> > Chrome beta: 8733ms
> 
> These are all measuring painting performance because the scrolling is driven
> by content script instead of happening asynchronously. They should probably
> all be separate bugs.

Martijn, can we get these filed seperately as requested?
Keywords: qawanted
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.