Simple Canvas drawing rendering incorrectly

VERIFIED FIXED in Firefox 12

Status

()

defect
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: adil, Assigned: jrmuizel)

Tracking

({regression})

12 Branch
mozilla13
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox12+ verified, firefox13+ verified)

Details

(Whiteboard: [qa!], )

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0a2) Gecko/20120219 Firefox/12.0a2
Build ID: 20120219042015

Steps to reproduce:

Open this URL http://jsfiddle.net/codepo8/ccvxy/


Actual results:

It drew a circular pattern in a new canvas element that did not look like a spider's web


Expected results:

Drawn a spider's web.
The page renders correctly in the Firefox 10 and Webkit.
Adil, would you be willing to find the regression range by any chance?
Looks like a regression in this range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=34572943a3e4&tochange=f4049f65efc6

Almost certainly a regression from Azure canvas on OSX.
Blocks: 692879
Status: UNCONFIRMED → NEW
Ever confirmed: true
Do you see the same problem on windows?
On Windows, I see correct rendering in both Firefox 10 and today's nightly.
From a quick test this issue started to happen from FF 12 on the Mac. I did not see the issue in FF 11.
This was a copy&paste typo
Attachment #599723 - Flags: review?(matt.woodrow)
Attachment #599723 - Flags: review?(matt.woodrow) → review+
Tracking for Firefox 12 and up since this is a recent regression and may cause web compatibility issues. The fix seems low risk, and we'd therefore like to get this uplifted to Aurora 12 if you agree.
Comment on attachment 599723 [details] [diff] [review]
Don't ignore curves when we don't have a current point

[Approval Request Comment]
Yes please.

This is low risk.
Attachment #599723 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/b63833059d11
Assignee: nobody → jmuizelaar
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
Attachment #599723 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [qa+]
Setting this as verified fixed on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0) Gecko/20100101 Firefox/12.0 beta 3

I've loaded the URL from the description an a spider web was displayed.
Verified fixed on FF 13b3: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:13.0) Gecko/20100101 Firefox/13.0
Status: RESOLVED → VERIFIED
Whiteboard: [qa+] → [qa!]
You need to log in before you can comment on or make changes to this bug.