"my" variable $fieldid masks earlier declaration in same scope at

RESOLVED DUPLICATE of bug 57848

Status

()

Bugzilla
Bugzilla-General
P2
normal
RESOLVED DUPLICATE of bug 57848
17 years ago
5 years ago

People

(Reporter: timeless, Assigned: justdave)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Running /usr/bin/perl -cw -I/home/ianh/tinderbox/mozilla/webtools/bugzilla/ 
-I/home/ianh/tinderbox/perllibs/lib/site_perl/5.005/i386-linux/ 
-I/home/ianh/tinderbox/perllibs/lib/site_perl/5.005/move.pl; Results:
move.pl has compilable perl syntax.
Warnings: 
"my" variable $fieldid masks earlier declaration in same scope at
  /home/ianh/tinderbox/mozilla/webtools/bugzilla/move.pl line 112 (#1)

(W) A lexical variable has been redeclared in the current scope or statement,
effectively eliminating all access to the previous instance.  This is almost
always a typographical error.  Note that the earlier variable will still exist
until the end of the scope or until all closure referents to it are destroyed

Comment 1

17 years ago
Created attachment 28448 [details] [diff] [review]
Patch

Comment 2

17 years ago
That one's fairly easy... just declare the variable at the begining of the if
block and use it later.
Keywords: patch
Target Milestone: --- → Bugzilla 2.16
Priority: -- → P2

Comment 3

17 years ago
This was already fixed in bug 57848.

*** This bug has been marked as a duplicate of 57848 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE
Assignee: endico → justdave
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Target Milestone: Bugzilla 2.16 → ---
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.