If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

unable to post from mail composition window

VERIFIED WORKSFORME

Status

MailNews Core
Composition
--
major
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
not sure if this is the right component, or if this should go to Composition.
found using 2001.03.21.08 comm bits on linux.

1. open a mail composition window: from the browser window i hit ctrl+M; from
the mail window, i clicked the New Msg button.
2. selected Newsgroup from the address droplist, and entered
netscape.public.test as the addressee.
3. entered some text for the subject and msg content.
4. clicked Send button.

results: dialog appears saying "Sending of message failed." console output:

SendMessage from XUL
GenericSendMessage from XUL
Identity = [nsIMsgIdentity: id2]
attachments = 
 RECEIVE ComposeProcessDone
failed to SendMsg

note: if you succeed in sending the first time, go thru the steps again
--subsequent attempts should fail. fwiw, i'm using a migrated IMAP acct. will
test with a new profile using a test acct...
(Reporter)

Comment 1

17 years ago
using the 3qatest01 imap acct, methinks i was able to repro this problem --with
a few differences:

* didn't get a dialog stating that sending failed.
* the mail composition window flashed for a brief moment after clicking Send.
* different console output:

SendMessage from XUL
GenericSendMessage from XUL
Identity = [nsIMsgIdentity: id1]
attachments = 
DetermineHTMLAction: preferFormat = -1, noHtmlRecipients are 
 RECEIVE ComposeProcessDone

just to be sure, i'll check netscape.public.test for my test post a bit later
[just in case the server is lagging behind]. the failure/success here would be
with an article whose subject is "foo3" from 3qatest01@mcom.com.

Updated

17 years ago
QA Contact: esther → sheelar
(Reporter)

Comment 2

17 years ago
something mysterious must've fixed this. no longer seeing this with a recent
linux build [from 5pm-ish]. will doublecheck with the next verif bits...
(Reporter)

Comment 3

17 years ago
okay, this is odd:

1. installed 2001.03.22.17 commercial verification bits using the installer stubs.
2. ran the same profile as i did in my previous comment.
3. opened a mail compose window and addressed to a newsgroup, etc.
4. click Send button.
result: fails to send.
5. rerun the same profile using my 5pm-ish build. repeat steps 3 and 4.
result: fails to send.

any ideas why this is happening?
(Reporter)

Comment 4

17 years ago
ignore my last comment. i'm getting the failure because i have the same profile
open with two builds [mozilla and netscape respin].

now i wonder whether this was originally due to something similar --although i
wouldn't think having both communicator 4.7x mailnews and netscape [as i prolly
had yesterday when i had filed this] would be the culprit. *shrug*

remaining question: is this expected behavior, ie, failing to send when there's
more than one instance of mailnews [different builds] running?
I wonder if it's related to bug 63162 were we have some writting error to the 
network socket!

Comment 6

17 years ago
Bug 81580 gives another scenario where posted message is silently lost.

Comment 7

16 years ago
Sairuh, we had a bug before where you couldn't send a msg from a lone 
composition window if no mail3pane was opened, was this what you experienced?

We fixed this recently, so I'd like to have an updated comment here from you 
wheter it worksforyou now.  Thanks.

(Besides, I bet this should be moved to the Composition component if it's still 
valid.)
(Reporter)

Comment 8

16 years ago
yep, wfm using 2001.11.01.12-comm bits on linux.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Component: Networking - News → Composition
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

16 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.