If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

IndexError: list index out of range when validating chrome manifest

VERIFIED FIXED in 6.4.5

Status

addons.mozilla.org Graveyard
Add-on Validation
P2
normal
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: kumar, Assigned: basta)

Tracking

unspecified
6.4.5
x86
Mac OS X

Details

STR:

Using https://addons.mozilla.org/firefox/downloads/file/121290/downloadsmod-0.1.1-fx.xpi?src=version-history

$ ./addon-validator -o json ~/Downloads/downloadsmod-0.1.1-fx.xpi
Traceback (most recent call last):
  File "./addon-validator", line 6, in <module>
    validator.main.main()
  File "/Users/kumar/dev/amo-validator/validator/main.py", line 119, in main
    for_appversions=for_appversions)
  File "/Users/kumar/dev/amo-validator/validator/validate.py", line 47, in validate
    timeout=timeout)
  File "/Users/kumar/dev/amo-validator/validator/submain.py", line 91, in prepare_package
    for_appversions)
  File "/Users/kumar/dev/amo-validator/validator/submain.py", line 171, in test_package
    output = test_inner_package(err, package, for_appversions)
  File "/Users/kumar/dev/amo-validator/validator/submain.py", line 341, in test_inner_package
    test_func(err)
  File "/Users/kumar/dev/amo-validator/validator/testcases/chromemanifest.py", line 88, in test_content_instructions
    elif not triple["object"].split()[0].endswith("/"):
IndexError: list index out of range
This might be blocking the Firefox 11 bump (bug 728951)
Assignee: nobody → mattbasta
Target Milestone: --- → 6.4.3
Matt - can you address this?  Let us know if you need any more info or an add-on attached here
Priority: -- → P2
Target Milestone: 6.4.3 → 6.4.4
(Assignee)

Comment 3

6 years ago
I can probably have this done tonight. I'll look at it in a bit.
(Assignee)

Comment 4

6 years ago
Fixed:

https://github.com/mattbasta/amo-validator/pull/29
(Assignee)

Comment 5

6 years ago
Oops, bad pull request. Fixed:

https://github.com/mozilla/amo-validator/pull/131
https://github.com/mozilla/amo-validator/commit/0f007265de307902caa582cf06aab75717efa189

Please verify functionality on -dev
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 733843
Did Zamboni's submodule get bumped to pull in the new validator changes?
(In reply to Kumar McMillan [:kumar] from comment #8)
> Did Zamboni's submodule get bumped to pull in the new validator changes?

I just updated it

Comment 10

6 years ago
The test .xpi passes validation without any errors. verified fixed at https://addons-dev.allizom.org/en-US/developers/upload/3171307f5d7f41ea80704903fa102373
Status: RESOLVED → VERIFIED

Updated

6 years ago
Target Milestone: 6.4.4 → 6.4.5
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.