Absolutely (or fixed) positioned table with top and bottom both 0 and auto height is shorter than the viewport

RESOLVED DUPLICATE of bug 691628

Status

()

RESOLVED DUPLICATE of bug 691628
7 years ago
7 years ago

People

(Reporter: mm.nl, Unassigned)

Tracking

({regression})

10 Branch
x86_64
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

59.13 KB, application/zip
Details
(Reporter)

Description

7 years ago
Created attachment 599384 [details]
code.zip

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120216100510

Steps to reproduce:

Load a page with an image.


Actual results:

The image is placed at the top of the page and truncated.


Expected results:

The image should be centered both horizontal and vertical.

See attached file.
It worked with Firefox 7, 8 and 9. Is broken since version 10.
It still works fine with Google Chrome, Konqueror, Krusader Viewer, Opera.

Firefox 10.0.2 Mozilla Firefox for Ubuntu canonical - 1.0
Linux kubuntu 2.6.38-13-generic #55-Ubuntu SMP
Tue Jan 24 15:34:24 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Comment 1

7 years ago
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/60e86b847759
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20110929 Firefox/10.0a1 ID:20110929122038
Fails:
http://hg.mozilla.org/mozilla-central/rev/af3668a89015
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20110929 Firefox/10.0a1 ID:20110929141938
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=60e86b847759&tochange=af3668a89015


In local build
Last Good : d5ec6fead55b
First Bad : 34f184d2a6f8

Triggered by:
34f184d2a6f8	Ehsan Akhgari — Bug 10209 - Part 5: Allow table elements to act as absolute positioning containers; r=roc
Blocks: 10209
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout
Ever confirmed: true
Keywords: regression
OS: Linux → All
Product: Firefox → Core
QA Contact: untriaged → layout
Attachment #599384 - Attachment mime type: application/octet-stream → application/zip
The key part is that this is an absolutely positioned table whose offsets are all set to 0 but whose height is auto.

Per spec, the height of such a table is ... contraductory; parts of the spec say it should be the height of the containing block (the viewport in this case) and other parts say it should be the height of the one cell (so in this case 256px or so).  It looks like we're making the table 256px tall.

Which makes this a duplicate of bug 691628.  Ehsan's post to www-style asking for a spec clarification never got a response....
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Summary: CSS3 { display: table-cell; vertical-align: middle; } BROKEN → Absolutely (or fixed) positioned table with top and bottom both 0 and auto height is shorter than the viewport
Duplicate of bug: 691628
You need to log in before you can comment on or make changes to this bug.