mime type issue, truncated contentsubtype on upload of pdf as text/xm

RESOLVED DUPLICATE of bug 373621

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 373621
7 years ago
5 years ago

People

(Reporter: bimperia, Unassigned)

Tracking

10 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

Uploading a pdf document using Firefox 10.0.2 


Actual results:

upon upload I encountered "The MIME type of the uploaded file text/xm was not accepted by the server. " using an upload tool that's been working fine for a few years now. Tested using IE and Safari as well without issue on WinXP SP3


Expected results:

well, in short the file should have uploaded. Can test for yourself here:
http://domint.med.unc.edu/test/index.cfm
Reporter

Updated

7 years ago
Severity: normal → major
Reporter

Comment 1

7 years ago
Tested this on an earlier version, 9 and it works fine fyi.
The MIME type sent will depend on your OS configuration and your helper application settings.  For example, for me it sends "application/x-pdf", which the site likewise does not accept.

That said, if 9 is using the same profile you should get the same behavior.  _Are_ you using the same profile with 9?
Reporter

Comment 3

7 years ago
the testing with version 9 was done on a completely different box so no the profiles were not the same. As for the OS config and mime types, the box this is on is set to accept "application/pdf" which as I mentioned has worked fine for a few years now with not change. The URL I supplied was for a bare-bones upload tool out of the context of any application scope so I could rule out any issues with application coding.
What does the mimeTypes.rdf in your profile have to say for the "text/xm" MIME type or the "pdf" extension?
Reporter

Comment 5

7 years ago
the first shows:
  <RDF:Description RDF:about="urn:mimetype:handler:text/xm"
                   NC:alwaysAsk="true"
                   NC:useSystemDefault="true"
                   NC:saveToDisk="false">
    <NC:externalApplication RDF:resource="urn:mimetype:externalApplication:text/xm"/>
  </RDF:Description>

for pdf it shows:
  <RDF:Description RDF:about="urn:mimetype:handler:application/pdf"
                   NC:alwaysAsk="true"
                   NC:useSystemDefault="true"
                   NC:saveToDisk="false">
    <NC:externalApplication RDF:resource="urn:mimetype:externalApplication:application/pdf"/>
  </RDF:Description>
Reporter

Comment 6

7 years ago
shouldn't the text/xm be text/xml ?
> for pdf it shows:

I was asking about entries that contain NC:fileExtensions="pdf".  Note that there might be more than one.

> shouldn't the text/xm be text/xml ?

That depends.  Entries in this file can come from types you've encountered on the web, so if someone sent text/xm, you can get a text/xm in this file.
Reporter

Comment 8

7 years ago
  <RDF:Description RDF:about="urn:mimetype:application/pdf"
                   NC:fileExtensions="pdf"
                   NC:description="Adobe Acrobat Document"
                   NC:value="application/pdf"
                   NC:editable="true">
    <NC:handlerProp RDF:resource="urn:mimetype:handler:application/pdf"/>
  </RDF:Description>
That's the only entry with NC:fileExtensions="pdf"?
Reporter

Comment 10

7 years ago
my bad, trying to get some coding done here meanwhile; 

  <RDF:Description RDF:about="urn:mimetype:text/xm"
                   NC:fileExtensions="pdf"
                   NC:description="Adobe Acrobat Document"
                   NC:value="text/xm"
                   NC:editable="true">
    <NC:handlerProp RDF:resource="urn:mimetype:handler:text/xm"/>
  </RDF:Description>
OK, that's what's going on.  Some file you dealt with had the extension "pdf" and the type "text/xm" and we remembered that file association...

There's an existing bug on that; in the meantime just deleting the text/xm stuff from that file while your browser is not running will help.
Whiteboard: DUPEME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373621

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.