MAPLE: BeginDrawing takes > 8 ms

RESOLVED DUPLICATE of bug 731603

Status

()

Core
Graphics
P1
normal
RESOLVED DUPLICATE of bug 731603
6 years ago
6 years ago

People

(Reporter: BenWa, Assigned: BenWa)

Tracking

(Blocks: 1 bug)

unspecified
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-fennec1.0 beta+)

Details

(Whiteboard: MAPLE mwc-demo [gfx])

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
We're spending too much in BeginDrawing, in some case as much time as we spend drawing. We need to get this call in the sub millisecond range.
Keywords: fennecnative-betablocker

Updated

6 years ago
Whiteboard: MAPLE mwc-demo
(In reply to Benoit Girard (:BenWa) from comment #0)
> We're spending too much in BeginDrawing, in some case as much time as we
> spend drawing. We need to get this call in the sub millisecond range.

FWIW, we only spend a long time some of the time.

Updated

6 years ago
Assignee: nobody → bgirard
Priority: -- → P1
https://hg.mozilla.org/projects/maple/rev/ce31a3b140a2 removes the transaction lock from beginDrawing/endDrawing so this should be faster now.
blocking-fennec1.0: --- → beta+
Status: NEW → ASSIGNED
Depends on: 731897
Blocks: 725095
(Assignee)

Comment 3

6 years ago
I don't think we should break for a specific performance problem is we think performance is good enough to land. Jeff already has a patch underway to address this.
(Assignee)

Comment 4

6 years ago
break=block landing*
No longer blocks: 725095
We're pretty sure this is gone, and we'll reopen if necessary.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
This is not yet finished.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Whiteboard: MAPLE mwc-demo → MAPLE mwc-demo [gfx]
Blocks: 734800
Created attachment 605565 [details] [diff] [review]
WIP

This WIP compiles (last time I checked) but doesn't run yet because the drawBackground() function in LayerRenderer.java calls rootLayer.getBounds which will need to be replaced with a display port coming in from the compositor.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 731603
Blocks: 717774
You need to log in before you can comment on or make changes to this bug.