Hotfix isn't downloaded and installed for a portion of users

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: mossop, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

We uploaded a test hotfix to AMO for the beta audience (then 10.0) and waited to see what sort of uptake there was. According to AMO stats out of a total apparent audience of 1.3m (the number of pings for the "invalid" version), we eventually reached around 1.0m about around 8 days at which point we had to disable the add-on.

After beta users got upgraded to 11.0 we uploaded a second test hotfix to AMO. After a week we're seeing just 35k users reporting having installed it with 1m users still showing 1.0 installed, which is ridiculously low.

As things stand we cannot rely on the hotfix support, we need to either figure out what the problem is and fix it or we might as well just rip it out.

The only thought I've had so far is that add-on sync might be a problem but my suspicion is that the user base isn't high enough there for this, it also doesn't explain the low (though not terrible) uptake for the 10.0 beta users.
(Reporter)

Updated

7 years ago
Blocks: 694068
Depends on: 719955, 724689
(Reporter)

Updated

7 years ago
Duplicate of this bug: 730034
One thing of note is that our QA testing did not involve a profile from when FF10 was on mozilla-beta and the v1 hotfix was installed. It instead involved installing FF10 beta, installing the v1 add-on hotfix by hand, then updating to FF11 beta and waiting for the hotfix to install.
(Reporter)

Comment 3

7 years ago
It looks like this is caused by bug 726811, the xpi file simply isn't present on the mirrors which makes installing it impossible. That is being fixed now but it does raise the question of how 30k users managed to install it in the first place...
Depends on: 726811
I retested this with 10.0b5 -> 11.0b4 on beta channel and did not encounter any problems. Of course this required me to manually install hotfix v1, I could not test the true path our users experience (ie. automatic install of v1 > update > automatic install of v2 > automatic removal of hotfix).

I even threw a couple extra add-ons into the mix pre and post hotfix to ensure no corruption.

I did not witness any problems whatsoever.
This can be closed out - with the latest hotfixes, we're already installed on 85% of >100m user installs. There have been no further issues with hotfix penetration
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.