Closed Bug 729780 Opened 8 years ago Closed 6 years ago

Nightly installer shows blank screen for about 15 seconds if Nightly is still running in the background

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
blocking-fennec1.0 --- -

People

(Reporter: cpeterson, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

I have Nightly 13.0a1 (2012-02-21) installed on my Galaxy Nexus.

STR:
1. Nightly alerts me that an update is available.
2. I download the update and run the installer.

AR:
The installer shows a blank screen for about 15 seconds before "Replace application?" dialog.

ER:
If I manually kill the Nightly process first, the installer does not hang.


I believe the problem is related to the Nightly process running in the background. adb logcat shows no activity during the installer hang until the following message:

W/ActivityManager(  197): Launch timeout has expired, giving up wake lock!
W/ActivityManager(  197): Activity idle timeout for ActivityRecord{41a660e0 org.mozilla.fennec/.Restarter}

* See the attached logcat log for more info. I periodically pressed the ENTER key while recording the log, so the blank lines in the log are during the installer hang.
Can you reproduce this all the time?
> *Can you reproduce this all the time?*

If Nightly is running/paused in the background, yes.
I can reproduce this on the HTC Desire HD, after upgrading from the 2012-03-01 Nightly to the 2012-03-04 Nightly build.

I couldn't reproduce this in a build from 2012-01-01, so this seems to be a regression.
Duplicate of this bug: 732944
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → -
Duplicate of this bug: 740838
Duplicate of this bug: 752058
If we do end up shipping any builds as web downloads that update over AUS, QA has flagged this bug as a specific concern. Nominating for blocking-fennec1.0.
blocking-fennec1.0: - → ?
minusing this for Fennec-1.0 important if we ship smaller locales as a manual download
blocking-fennec1.0: ? → -
qawanted, is this still reproducible? I don't think I've seen this problem recently.
Keywords: qawanted
I'm definitely still seeing this while I updated from the 2012-05-31 build to the 2012-06-01 build on the Samsung Galaxy SII.
Keywords: qawanted
FWIW I can still reproduce this problem on recent Nightly builds on a Samsung Galaxy S2.
Sriram saw the cause of this while looking into restarting Fennec after a locale change, IIRC. The Restarter is waiting for the Fennec process to die before it can start a new one. The new process sees the update and starts the installation.
We should change it to a Dialog (style Activity) instead of occupying full screen, with a message saying "Restarting.. " (and a spinning throbber). This is more meaning than an empty activity without any message.
Depends on: 786380
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.