Show download percentage complete in Windows/Mac taskbar

VERIFIED FIXED in Future

Status

Core Graveyard
File Handling
P3
enhancement
VERIFIED FIXED
17 years ago
a year ago

People

(Reporter: Peter Lairo, Assigned: Bill Law)

Tracking

Trunk
Future
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Download window should show percentage complete in titlebar. 

This would be extremely useful since if the user decides not to minimize the
window (novice users), it is very common to switch back to the browser and have
only the titlebar of the download manager visible above the windowed browser
window. The progress bar would be hidden (I do this *ALL* the time), so the only
clue as to how far along the download is would be the percentage complete in the
title bar of the download window.

If it's all the same, I would also suggest to place the filename in the titlebar
as well (for the same reasons) :)

Bothe these solutions would be particularly usefule for when one has multiple
downloads going on at the same time. One could align the download windows along
the top of the screen, contiue browsing, and still see how far along the
downloads are. Very cool :)

The percentage complete should be on the left, then the filename, then (if
necessary) "Saving File". Yeah Baby

Comment 1

17 years ago
I fully agree it's useful, but isn't this another dup of bug 35046?
"[RFE] Show download progress (%) in title when minimized"
(Reporter)

Comment 2

17 years ago
No, that's my point, when *not* minimized! When minimized it should show in the
win *taskbar* (bug 35046); when *not* minimized, it should show in the download
windows *titlebar*. :)

Comment 3

17 years ago
Easyest would be to have it show as part of window title regardless.
Then the taskbar window icon would display percentage whether minimized or not.
Just have the percentage mentioned as first part of the windowname, so a narrow
taskbar-icon still would contain the digits.

Comment 4

17 years ago
Isn't the title in the taskbar just the same as the window titlebar?
(Reporter)

Comment 5

17 years ago
The *Titlebar* is what is shown in the top portion of each window.

The *Taskbar* is the grey bar on the *bottom* of your screen between the start
button and the clock (in Windoze).

All clear? ;)

Comment 6

17 years ago
I meant, isn't the text in the taskbar just copied from whatever is in the 
titlebar?  i.e. they're not separate attributes, just different displays of the 
window title?

Comment 7

17 years ago
They are one and the same attribute. I think we should mark this as a dup of
35046, as that also has the dicussion on whether it should be always or just
when minimised.
(Reporter)

Comment 8

17 years ago
No, we should keep this bug open. The other bug's title is still "[RFE] Show
download progress (%) in title when *MINIMIZED*"!

And since mozilla operators are very particular about keeping bugs separate and
distinct, we should keep this bug open until it is fixed or the other bug's
summary is changed.
(Reporter)

Updated

17 years ago
Keywords: helpwanted

Comment 9

17 years ago
Since the discussion in bug 35046 seems to conclude that the %age should not be
shown when the window is visible, should this be marked WONTFIX?
This should be a dupe of bug 35046.
Bugs 35046 summary should changed to "Download window should show percentage
complete in titlebar".
I think this would be the best.

(I reassign this bug to matthew@mjwilson.demon.co.uk who owns bug 35046)
Assignee: asa → matthew
Component: Browser-General → XP Apps: GUI Features
QA Contact: doronr → sairuh
(Reporter)

Comment 11

17 years ago
I'll agree, if the summary of the other bug is changed.

The percentage comple must *not* be limited to the minimized state.

Comment 12

17 years ago
Peter Lairo, This is a request for a change in the design.  UI changes should go
through a design process before an implementation process.  If you feel strongly
that a UI change is called for then create a proposal (spec) and post it to the
UI newsgroup for review.  If the spec is reviewed and approved by UI folks (mpt,
german, bengoodger, etc.) then it can go to implementation.   

Comment 13

17 years ago
Moving and Marking NEW.
Assignee: matthew → mpt
Status: UNCONFIRMED → NEW
Component: XP Apps: GUI Features → User Interface Design
Ever confirmed: true
QA Contact: sairuh → zach
(Reporter)

Updated

17 years ago
Keywords: mozilla0.9.1

Comment 14

17 years ago
It's entirely possible for a window to show something other than the window 
title in the Windows taskbar. Norton AntiVirus does this, for example, when 
scanning for viruses.

I think it would be a very good idea to do this, regardless of whether or not 
the window is minimized (because the window might be behind a bunch of others). 
So I'm resummarizing this bug, because if I don't then this is indeed a dup of 
bug 35046.
Assignee: mpt → blakeross
Component: User Interface Design → XP Apps: GUI Features
OS: All → Windows 95
QA Contact: zach → sairuh
Summary: Download window should show percentage complete in titlebar → Show download percentage complete in Windows taskbar

Comment 15

17 years ago
mpt, I don't think we have independent control of the two pieces of text in 
XUL, though.

My personal opinion is that we should implement "%age in at all times" - a 
useful feature that we are currently lacking - and then later consider 
refinements (such as whether we can have separate text in the title bar and 
taskbar). At the moment we are letting the best be the enemy of the good.

Comment 16

17 years ago
--> law
Assignee: blake → law
Keywords: mozilla0.9.1
(Reporter)

Updated

17 years ago
Keywords: mozilla0.9.2

Comment 17

17 years ago
nav triage team:

Should put %-age in the title of the download window. Marking nsbeta1+, p3, and
mozilla1.0
Keywords: nsbeta1+
Priority: -- → P3
Target Milestone: --- → mozilla1.0
spam: over to File Handling.
Component: XP Apps: GUI Features → File Handling
(Assignee)

Comment 19

16 years ago
->mozilla0.9.9
Target Milestone: mozilla1.0 → mozilla0.9.9

Comment 20

16 years ago
*** Bug 110429 has been marked as a duplicate of this bug. ***
*** Bug 113571 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

16 years ago
Keywords: mozilla0.9.7
(Assignee)

Updated

16 years ago
Depends on: 27609
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: mozilla0.9.9 → ---
(Assignee)

Updated

16 years ago
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 22

16 years ago
Spam: Setting target milestone for all these to Future.

Please note that most, if not all, will be fixed in the course of the work I'm 
doing for bug 27609.  That fact is noted in the "depends on" field for each of 
these bugs (I think; go ahead and remedy that if you like).

I just don't have time to deal with the wrath that comes with having too many 
bugs.
Target Milestone: mozilla1.0 → Future
(Reporter)

Updated

16 years ago
Keywords: helpwanted, mozilla0.9.7 → mozilla0.9.9, nsbeta1
(Assignee)

Comment 23

16 years ago
fixed as part of the new progress dialog for bug 27609
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
this has been fixed for some time in both win32 and mac builds. (n/a for
linux/unix.)
Status: RESOLVED → VERIFIED
Summary: Show download percentage complete in Windows taskbar → Show download percentage complete in Windows/Mac taskbar

Comment 25

13 years ago
*** Bug 257907 has been marked as a duplicate of this bug. ***
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.