If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mouseover event handler failure on nearly horizontal SVG lines

RESOLVED DUPLICATE of bug 676001

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 676001
6 years ago
6 years ago

People

(Reporter: Stephan A., Unassigned)

Tracking

10 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

I used a mouseover event handler on SVG lines to show a self made context menu.


Actual results:

This works for nearly horizontal lines only until Firefox 3.6, probably not in Firefox 4, and surely not in later versions. Only on some few points of a nearly horizontal line, the context menu is shown.
On all (or nearly all, I have not extensively tested it) other lines (that are not nearly horizontal), also on exactly horizontal lines, the context menu works correctly as in FF 3.6.
When I change the nearly horizontal lines to a greater width (approx. 2 times as before), it's the same thing as before. It seems not to depend on the line width.
You can prove this error in the upper right window of  the program window started by the site
http://www.constructor.valvegear.de/start.php?webfile=xtern.vgc.valvegear.de/webfiles/webfile1.vgc


Expected results:

??? The problem does only appear in a FF later than 3.6. So what should have happened? A newer Firefox should behave just like an older one in this basic case...
(Reporter)

Updated

6 years ago
Duplicate of this bug: 729932
(Reporter)

Comment 2

6 years ago
@Robert L.: Yes, it seems to be the same effect as in bug 676001!


--- Comment #1 from Robert Longson <longsonr@gmail.com> 2012-02-23 07:17:13 PST ---
Is this bug 676001?

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 676001
You need to log in before you can comment on or make changes to this bug.