Select box(Dropdown), selected option is not displaying assigned color

RESOLVED DUPLICATE of bug 79107

Status

()

RESOLVED DUPLICATE of bug 79107
7 years ago
4 years ago

People

(Reporter: amey7p, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.38 KB, text/html
Details
(Reporter)

Description

7 years ago
Created attachment 600012 [details]
test.html

User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.56 Safari/535.11

Steps to reproduce:

I have one select box, containing 7 values & each value has some color associated with it, now when this select box is rendered; one can see different colors in drop down but if any value is selected then color assigned to same gets vanished.Refer attached test.html.This works properly in IE but fails in Firefox.


Actual results:

Color of selected option gets vanished


Expected results:

Color of selected option should remain same,This works properly in IE but fails in Firefox.

Updated

7 years ago
Attachment #600012 - Attachment mime type: text/plain → text/html

Comment 1

7 years ago
Confirmed on 3.6.27 and Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20120223 Firefox/13.0a1 ID:20120223031236

However, the testcase only appears to work in IE. (Tested Safari and Opera)
Version: 10 Branch → Trunk
(Reporter)

Comment 2

7 years ago
So you are considering this as firefox bug or firefox limitation?

Comment 3

7 years ago
(In reply to amey from comment #2)
> So you are considering this as firefox bug or firefox limitation?

Just stating what I found

This might be a duplicate of bug 79107
(Reporter)

Comment 4

7 years ago
bug talks about expand/collapse of select box, this scenario is selected option's color gets vanished; agree reason both for behavior might be same; bug you are saying is reported in 2001 & we are in 2012 now; still it is in pending status

Comment 5

6 years ago
CONFIRMED this is a bug, CONFIRMED it is a duplicate of bug 79107 and CONFIRMED it needs get fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 79107
You need to log in before you can comment on or make changes to this bug.