If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Invalid URL for APPS Homepage is allowed.

VERIFIED FIXED in 6.4.3

Status

addons.mozilla.org Graveyard
Developer Pages
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: Victor Carciu, Assigned: cvan)

Tracking

unspecified
6.4.3

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 600026 [details]
Warning for invalid URL entered during app submission.

Prerequisites:
Mozilla/5.0 (Windows NT 5.1; rv:10.0) Gecko/20100101 Firefox/10.0

Steps to reproduce:
1.Go to APPS marketplace : https://marketplace-dev.allizom.org/en-US/developers/ ,login with valid credentials and be sure that you already have some apps submitted.
2.From My Submissions , select an app and open it.
3.At "App Details" section click edit and enter an invalid URL.
4.Click "Save changes"

Expected results:
A warning asking for a valid URL should be displayed.

Actual Results:
The invalid URL is saved as Homepage .

NOTES: I logged this issue because I observed that during app submission process, the user is forced to enter valid URL for Homepage(attached screenshot with the warning displayed for invalid URL). 

Please see screencast for this bug: http://screencast.com/t/FZc5ai5h3
(Assignee)

Comment 1

6 years ago
https://github.com/mozilla/zamboni/commit/e4ff99b
Assignee: nobody → cvan
Status: NEW → RESOLVED
Last Resolved: 6 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 6.4.3
(Reporter)

Comment 2

6 years ago
Verified as fixed.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

6 years ago
Created attachment 600376 [details]
Postfix Screenshot.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.