Work with Vid.ly to get a properly signed ssl certificate

VERIFIED FIXED

Status

Websites
Firefox Flicks
P2
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: ckoehler, Assigned: chelsea)

Tracking

Details

(Reporter)

Description

6 years ago
Vid.ly currently supports ssl on embedded videos, but only has a self-signed certificate. Because we need to use ssl on Firefox Flicks, some users will experience mix-content warnings unless we use ssl for Vid.ly as well.

Let's work with Vid.ly to ensure they have a properly signed ssl certificate in time for the Firefox Flicks launch.

Updated

6 years ago
Duplicate of this bug: 728721
As per bug 728721 comment 2, we're currently better off serving the vidly pieces as HTTP (resulting in a mixed content warning for few users) than broken HTTPS (resulting in invisible content for most users). Either possibility sucks and a fixed SSL cert is the only real solution to this.
(Reporter)

Comment 3

6 years ago
I don't actually consider this a duplicate of bug 728721. That bug tracks the code changes that are required and this bug is to track Chelsea's task of getting Vidly to set up the cert.
(Reporter)

Updated

6 years ago
Summary: Enable SSL on Vid.ly Embeds → Work with Vid.ly to get a properly signed ssl certificate

Updated

6 years ago
Blocks: 728721
Sorry about that, I unduped it.
(Reporter)

Updated

6 years ago
Priority: -- → P2
(Reporter)

Updated

6 years ago
Blocks: 700465
No longer blocks: 720430
(Assignee)

Comment 5

6 years ago
Update from Vidly

They have a fix on the SSL cert issue that's currently in QA - they hope it will go live in the next day or two.
If this is ready, can someone assign to me with the new https urls? (assuming they differ from the old urls because they are secure.. else just let me know that I only need to prepend with https) - thanks!
Any updates? This is something I'd love to lump into the next update if it works.
(Assignee)

Comment 8

6 years ago
They sent us a note to let us know that it's up an running on their end. What do you need from them?
I talked with their support and got a link to their knowledgebase article:

http://www.encoding.com/how_do_i_use_the_https_version_of_vid.ly_urls_and_thumbnails

The issue is that the URL for their video embeds uses the wrong certificate; the domain is s.vid.ly, but the certificate is valid only for '*.cloudfront.net , cloudfront.net'.

I'll try and contact their support staff tomorrow to see if there is an alternative URL, and if not, we'll have to either push them to get the correct SSL certificate, or consider setting up an SSL proxy (if that is feasible).
Marking this as resolved. Subsequent talks with vid.ly support has shown that they indeed now have valid SSL certificates that work for our use case.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Verified FIXED, since I also verified bug 728721.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.