Closed Bug 729996 Opened 9 years ago Closed 9 years ago

SVG: space being incorrectly inferred in <text> content

Categories

(Core :: SVG, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla13

People

(Reporter: mkorourk, Assigned: longsonr)

References

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

Attached image text.svg
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.56 Safari/535.11

Steps to reproduce:


Open the attached SVG file containing a line of text and an outline of what the line of text should look like.


Actual results:


The first line is incorrectly shifted to the left


Expected results:


The two lines should look identical.

When there is a line break between the last </tspan> and the </text> tag, IE is incorrectly inferring an implied space.

Per the SVG spec (section 10.15), you should "strip out all trailing space characters (i.e., strip out space characters before "</text>")".

Chrome handles this correctly.
Can you attach a screenshot. I don't think I have the fonts you have installed so I'm not seeing what you are? Perhaps you could also attach a screenshot from Chrome showing what it's supposed to look like.

You are seeing this on Firefox 10 aren't you?
Component: Untriaged → SVG
Product: Firefox → Core
QA Contact: untriaged → general
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch patch (obsolete) — Splinter Review
need to work on a reftest
Assignee: nobody → longsonr
(In reply to Robert Longson from comment #1)
> Can you attach a screenshot. I don't think I have the fonts you have
> installed so I'm not seeing what you are? Perhaps you could also attach a
> screenshot from Chrome showing what it's supposed to look like.
> 
> You are seeing this on Firefox 10 aren't you?

Actually never mind, I worked it out.
Attached patch patch with testSplinter Review
Attachment #600079 - Attachment is obsolete: true
Attachment #600131 - Flags: review?(dholbert)
OS: Windows 7 → All
Hardware: x86_64 → All
Version: 10 Branch → Trunk
Last good nightly: 2011-05-04
First bad nightly: 2011-05-05

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c3c4c902e9cd&tochange=31879b88cc82

Looks like a regression from bug 620286.
Blocks: 620286
Keywords: regression
Attachment #600131 - Flags: review?(dholbert) → review+
(here's a clearer standalone testcase, based on longsonr's reftest, just to make this bug easy to see / test)
pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/c65342fe6704

Thank you for the testcase Michael.
Flags: in-testsuite+
Target Milestone: --- → mozilla13
https://hg.mozilla.org/mozilla-central/rev/c65342fe6704
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.