Last Comment Bug 730072 - Quick Filter Toggle is gone (or doesn't move from tabbar toolbar) on upgrade to TB 11 with Enigmail and/or Lightning installed
: Quick Filter Toggle is gone (or doesn't move from tabbar toolbar) on upgrade ...
Status: RESOLVED FIXED
[fixed by changes in extensions]
:
Product: Thunderbird
Classification: Client Software
Component: Toolbars and Tabs (show other bugs)
: 11 Branch
: x86 All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 730078
Blocks: 717264
  Show dependency treegraph
 
Reported: 2012-02-23 12:42 PST by Mike Conley (:mconley) - (needinfo me!)
Modified: 2012-03-06 12:28 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed
+
fixed


Attachments
Localstore.rdf for testing (5.37 KB, application/rdf+xml)
2012-02-23 12:44 PST, Mike Conley (:mconley) - (needinfo me!)
no flags Details

Description Mike Conley (:mconley) - (needinfo me!) 2012-02-23 12:42:22 PST
Bug 717264, which moves the Quick Filter Bar toggle from the tabbar-toolbar to mail-bar3, landed earlier this week, and we're getting sporadic reports that the toggle isn't moving OR is disappearing in some cases.

Chris might correct me here, but I think the steps to reproduce are as follows:

1)  In a recent TB 11, install Enigmail or Lightning in a new profile.
2)  Set mail.ui-rdf.version to 2, and shut down Thunderbird
3)  Replace the localstore.rdf for the new profile with the one attached to this bug
4)  Start up TB

What happens?

According to Chris Coulson, with Lightning installed the toggle stays where it is.  With Enigmail installed, the toggle disappears from the toolbars.

What's expected?

The QFB toggle should be in the mail toolbar (mail-bar3).

Reports for this have cropped up for both OSX and Linux, so I'll assume it affects all platforms.
Comment 1 Mike Conley (:mconley) - (needinfo me!) 2012-02-23 12:44:03 PST
Created attachment 600141 [details]
Localstore.rdf for testing
Comment 2 Mike Conley (:mconley) - (needinfo me!) 2012-02-23 12:48:11 PST
Ludo:

Do you know any Enigmail hackers we should CC on this?

-Mike
Comment 3 Chris Coulson 2012-02-24 02:42:18 PST
This doesn't look like a bug with the migration code. As Mike pointed out on IRC, there are no settings for mail-bar3 or tabbar-toolbar in my localstore.rdf, but DOM inspector seems to show that the QFB is still in the defaultset for the tabbar-toolbar after the upgrade
Comment 5 Mark Banner (:standard8) 2012-02-24 02:51:52 PST
The lightning part is covered in bug 730078, but I'm tracking this bug until we get that fixed so that we know we're a bit more covered for the release.
Comment 6 Chris Coulson 2012-02-24 04:09:13 PST
Thanks. I've just attached a patch which doesn't hardcode the defaultset at all in lightning
Comment 7 Patrick Brunschwig 2012-02-26 04:05:49 PST
I fixed this for Enigmail. But I have two requests for the future:

(1) Given the 6 weeks release cycle I would really appreciate if there were no such late changes on comm-beta. I need 3 weeks to obtain review approval on AMO(!), therefore I am already in the process of creating a new release; now I'll have to restart, and the deadline is almost impossible to reach.

(2) In the past, changes to mail-bar would have caused the ID to change (e.g. mail-bar2 to mail-bar3). This would allow add-ons to behave correctly for several versions of Thunderbird.
Comment 8 Mike Conley (:mconley) - (needinfo me!) 2012-02-28 08:40:45 PST
Patrick:


(In reply to Patrick Brunschwig from comment #7)
> I fixed this for Enigmail. But I have two requests for the future:
> 

Thank you!

> Given the 6 weeks release cycle I would really appreciate if there were no such 
> late changes on comm-beta.

Absolutely, and I apologize (and agree!) whole-heartedly.

I should have pushed back on this change more.  Next time, I'll push back harder - because you're right, it's really not fair for add-on developers to change things like this in the 11th hour.

> (2) In the past, changes to mail-bar would have caused the ID to change
> (e.g. mail-bar2 to mail-bar3). This would allow add-ons to behave correctly
> for several versions of Thunderbird.

I believe changing the ID would cause your overlays, and any code that queries for the mail bar at runtime to fail.

It would also completely wipe-out persisted user-customizations for that toolbar.

We've adapted Firefox's approach to this, which is to run a migration function on startup, that - if necessary - makes the appropriate changes to the toolbars, instead of using the nuclear option (changing the toolbar ID).

Thanks for your work,

-Mike
Comment 9 Philipp Kewisch [:Fallen] 2012-03-01 03:32:18 PST
The lightning part is now pushed, I'll be spinning a beta build tomorrow.
Comment 10 Mark Banner (:standard8) 2012-03-06 12:28:43 PST
So as far as we know, this is now fixed because the extensions have been fixed. Hence closing the bug down.

Note You need to log in before you can comment on or make changes to this bug.