Shouldn't have to sign in to *read* the Talk page

RESOLVED DUPLICATE of bug 715594

Status

Mozilla Developer Network
User management
RESOLVED DUPLICATE of bug 715594
6 years ago
5 years ago

People

(Reporter: mats, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

6 years ago
STEPS TO REPRODUCE
0. make sure you're not logged in to MDN
1. load https://developer.mozilla.org/en/XMLHttpRequest
2. move the mouse over "This Page" in the upper right corner and
   click "Talk page"
...

ACTUAL RESULT
I'm redirected to  https://developer.mozilla.org/en-US/

It's unclear to me what that page has to do with the Talk page that I
wanted to see.  Is it asking me to sign in?  there's no indication
of that whatsoever.  If there is no Talk page, it should just say so.

EXPECTED RESULT
The Talk page for the "XMLHttpRequest" page.  I shouldn't have to sign in
to *read* it.

=======

... continuing:
3. I sign in
4. clicking Back to get to page I wanted to see at 2.

ACTUAL RESULT
I see this message:
    You do not have permissions to view this page - please try logging in.
    You do not have permissions to view this page - please try logging in.
    You do not have permissions to view this page - please try logging in.

5. Shift->Reload

ACTUAL RESULT
The error message above disappears and I can now see that there is no content
on this page.

*sigh*

What I want to see after clicking "Talk page" when not signed in is:

The content of the Talk page, or a message stating that there is no content
on it yet, and a button "You can contribute".  If I click that button
I should be asked to signin, and after signing in is complete I should end up
at the Talk page that now shows the editor (which should not show up unless
signed in).
This sucks, but it's a known bug the way we have MindTouch and django configured. One of the many reasons we're moving off MindTouch as quickly as possible.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 715594
(Assignee)

Updated

5 years ago
Component: Administration → User management
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.