If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

there is no way to make a tab the rightmost app-tab by drag'n'dropping

REOPENED
Unassigned

Status

()

Firefox
Tabbed Browser
REOPENED
6 years ago
3 years ago

People

(Reporter: Johannes Linke, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa+])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
to reproduce: try to drag a tab to the right of the rightmost app-tab, with the intend to make it the new rightmost app-tab. it does not work here, the arrow indicating where the tab will go will be to the laft of the leftmost normal tab.

when the tab bar is not overflown, this is somewhat reasonable, but its still not perfect as you can't make a tab the rightmost app-tab by dragging it.

when the tab bar is overflown, this is weird, as the overflow widget marks a clear border between app-tabs and normal tabs and a user would expect that indicator-arrow to be to the right of the rightmost app-tab when trying to drag a tab to the left of the overflow widget.
(Reporter)

Comment 1

6 years ago
Created attachment 600346 [details]
image showing the problem

red dot marks cursor position

Updated

6 years ago
Component: Toolbars → Tabbed Browser
QA Contact: toolbars → tabbed.browser

Comment 2

6 years ago
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:13.0) Gecko/20120301 Firefox/13.0a1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0

This issue reproduces on the above builds.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [qa+]

Updated

6 years ago
OS: Windows 7 → All
Hardware: x86_64 → All
Version: 11 Branch → Trunk
(Reporter)

Comment 3

4 years ago
it seems like it is impossible to make a tab an app-tab per dragndrop in australis at all.

if this is intended, this bug can be closed.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Comment 4

3 years ago
actually this is still relevant for tabs dragged from other windows
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
You need to log in before you can comment on or make changes to this bug.