Initial space dropped on copy operations

VERIFIED WORKSFORME

Status

()

defect
VERIFIED WORKSFORME
8 years ago
7 years ago

People

(Reporter: alex_mayorga, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

STR:
Select some text including an initial space (i.e " as Duplicate" under the "Additional Comments" box on this bug).
Paste it in a text box for "Additional Comments".

Result:
The initial space is removed and results on "as Duplicate".

Expected result:
The initial space is kept and results on " as Duplicate".

Configuration:
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:13.0) Gecko/20120223 Firefox/13.0a1 ID:20120223031236

Initially reported on mozillaZine forums[1] where fellow Nightly tester bjherbison commented:

"Yep, same as with Firefox 3.6 and Firefox 10. I didn't know if it is as designed. You get the same result pasting to another application, the issue is with the copy not the paste."

[1] http://forums.mozillazine.org/viewtopic.php?p=11765765#p11765765
If I copy the text in your comment in this bug, the precedent space is preserved when copying to mozillazine's or bugzilla's text box.
However if I copy the text in mozillazine, the precedent space is omitted.
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/809f3ae9b071
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100920 Firefox/4.0b7pre ID:20100921035219
Fails:
http://hg.mozilla.org/mozilla-central/rev/27df5529f2cf
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100920 Firefox/4.0b7pre ID:20100921065251
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=809f3ae9b071&tochange=27df5529f2cf
Suspected:
bug 564737
Blocks: 564737
Component: Untriaged → Serializers
Keywords: regression
Product: Firefox → Core
QA Contact: untriaged → dom-to-text
Don't know what fixed it, but this now WFM on Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120619030538

I can copy " as Duplicate" and it pastes with the space on the comments box on this bug and in notepad.exe
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.